VSS Failed - W2k8 R2

Last post 11-27-2013, 12:39 PM by Ali. 8 replies.
Sort Posts: Previous Next
  • VSS Failed - W2k8 R2
    Posted: 06-27-2012, 10:01 AM

    Good Morning,

    I have a Windows Server 2008 R2 client that has thousands of VSS errors in the eventlog. The commvault backupjob is set to include the system state and has no errors in it, but the OS is going crazy.

    Volume Shadow Copy Service error: Error calling a routine on a Shadow Copy Provider {a4b3467a-2462-442b-8699-bbad76968c76}. Routine details Cannot ask provider {a4b3467a-2462-442b-8699-bbad76968c76} if volume is snapshotted. [0x80004005] [hr = 0x80004005, Unspecified error

    ].

     

    I found a few docs refering to the 17:55 error, which I am not having. But I did run the various VSSadmin utilites, and that provider is:

    Provider name: 'Galaxy VSS Provider Service'
       Provider type: Software
       Provider Id: {a4b3467a-2462-442b-8699-bbad76968c76}
       Version: 1.0.0.1

     

    One of the MS docs suggested restarting the server, so I did that last night and it didnt seem to help at all. None of the "Writers" appear to have any errors either. Where can I go from here.

     

    Thank you for your time.

  • Re: VSS Failed - W2k8 R2
    Posted: 06-27-2012, 10:35 AM

     

    Are you using snapProtect on this machine?  Is there a reason the CV vss provider is installed? 

    Either uninstall the CV VSS provider OR use the registry key below.

    Please add the following registry key to the client. This will make sure the MSFT Provider is used and not the alternate provider.

     

    Under HKEY_LOCAL_MACHINE\SOFTWARE\CommVault Systems\Galaxy\Instance00X\FileSystemAgent

     

    Create a new DWord Value called nUseVSSSoftwareProvider and give it a value of 1

    Then run the backup and see if the error cease. 

     

  • Re: VSS Failed - W2k8 R2
    Posted: 06-27-2012, 5:15 PM

    Vincenzo,

     

    Thank you for your reply, turns out we are not using snapProtect. It must have been a mis-click on install. I will remove it tonight and let you know how it goes. Thank you again.

     

     

    Denys

  • Re: VSS Failed - W2k8 R2
    Posted: 06-28-2012, 9:29 AM

    Vincenzo,

     

    Just wanted to follow up and say thank you, the problem was resolved. We removed CV VSS and all is well.

     

     

    Have a great day.

     

    Denys

  • Re: VSS Failed - W2k8 R2
    Posted: 06-28-2012, 9:55 AM

    Awesome, thanks for marking my post resolved!

  • Re: VSS Failed - W2k8 R2
    Posted: 07-02-2012, 12:00 AM

    i have the same problem, where snap protect is not enabled. the subclient is configured to use VSS, i tried disabling VSS and also the reg key, any other help would be appreciated.

  • Re: VSS Failed - W2k8 R2
    Posted: 07-02-2012, 9:15 AM

    Is it referecing the exact same provider ID?  If its not it could be something else. 

     

    Post the event viewer message as the reg key or uninstalling the CV VSS provider should correct the problem (if you are not using snapprotect this should be uninstalled)

  • Re: VSS Failed - W2k8 R2
    Posted: 11-21-2013, 12:16 PM

    I am getting almost the same error message but it is using the system vss provider:

     

    Volume Shadow Copy Service error: Error calling a routine on a Shadow Copy Provider {b5946137-7b9f-4925-af80-51abd60b20d5}. Routine details EndPrepareSnapshots({7cba73cd-07c4-4c50-a429-e2ff98f7b22c}) [hr = 0x8000ffff]. 

    Operation:
    Executing Asynchronous Operation

    Context:
    Current State: DoSnapshotSet
     
    Any ideas what could be causing that?
    The CommVault VSS provider is installed on the Server.
  • Re: VSS Failed - W2k8 R2
    Posted: 11-27-2013, 12:39 PM
    • Ali is not online. Last active: 07-03-2019, 12:32 PM Ali
    • Top 10 Contributor
    • Joined on 08-05-2010

    Hi, SHER-WG, are you using SnapProtect, and do you need the CV VSS Provider installed, or do you have other VSS providers running on that machine?  You could use the key mentioned above to override the default behavior.

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy