Ways to increase performance / responsiveness of CommCell DB?

Last post 09-22-2010, 11:10 AM by bolsen. 3 replies.
Sort Posts: Previous Next
  • Ways to increase performance / responsiveness of CommCell DB?
    Posted: 09-21-2010, 12:53 PM

    We've just rebuilt/upgraded our CommCell server and we're experiencing more GUI latency than before (right clicking or opening property sheets takes 30 seconds).  What would cause this type of latency?

     

    On a side note, I've noticed the new server uses very little of the 16GB of available RAM.  Can I reconfigure the CV DB to use more RAM?

  • Re: Ways to increase performance / responsiveness of CommCell DB?
    Posted: 09-21-2010, 3:19 PM

    Hi Bolsen,

    This is an extract I have found in the past in soe CommVault Documetation, I have had instances when I could not do what it suggests, but this is a standard tweak we do on all CommServe installations when we have lots of free mem:

    After installing the CommServe Software, the SQL Server instance COMMVAULT requires specific settings. In the Memory tab, the dynamically configured Maximum memory should be 50% of the physical memory available in the CommServe machine. The Memory tab is located in the Properties screen for the CommVault instance, and is accessible from the SQL Enterprise Manager.

    Obviously this could be tweaked a lot more if you have the ram.

  • Re: Ways to increase performance / responsiveness of CommCell DB?
    Posted: 09-21-2010, 6:20 PM

    Good note Andreas, the contractor who installed ours didnt set this and it was on the default on 0 as min and 1024 as max.  Have tweaked after talking to our DBA so min and max is 50% of the server memory.

  • Re: Ways to increase performance / responsiveness of CommCell DB?
    Posted: 09-22-2010, 11:10 AM

    Update -  the problem is resolved by setting the SQL server Min/Max memory to 50% installed RAM. 

    If you continue to experience latency, consider the following:

    1. Cornfirm the SQL server Min/Max memory is to 50% of installed RAM. 
      1. Note, you may have to reboot the server for the changes to take effect.
    2. Confirm read and write cache are enabled on the RAID controller.
      1. Note, Dell servers default setting = no read cache!
    3. Verify the page file is on different spindles (i.e. physical disks) than the database.
    4. Confirm CPU Adjacent Sector Prefetch is enabled in the server BIOS.
      1. Consider enabling the CPU Hardware Prefetcher (you should do before and after tests to confirm this helps). 

    These changes can make a HUGE difference in performance!  At a minimum, the memory setting recommendation should be added to the Knowledge Base!

    Thanks for the help!

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy