Failed to delete mount path due to SIDB

Last post 10-29-2010, 12:58 AM by AMJ. 7 replies.
Sort Posts: Previous Next
  • Failed to delete mount path due to SIDB
    Posted: 10-18-2010, 11:59 PM

    I'm trying to remove a number of luns from our maglib.  If i right click and list contents they all come up saying there is no valid content on them.  All of the data has been aged off or the jobs deleted. 


    The error i'm getting says :

    "Failed to delete the mount path XXXXXXXXXX.   Error : Mount path is used by a deduplication store. the data on this mount path used by the SIDB could be reference by other backup jobs. the mount path can be deleted only when all of the storage policies which are pointing to this mount path and using an SIDB are deleted.  

    Do you want to remove the entry from the database? removing the entries from the database will not delete the data from the physical disk."

    So far as i can tell there IS no data on the luns thats relevant.   I don't really want to delete storage policies as they are in use... and none of them store theri SIDB on the maglib anyway.  

    Go ahead and delete from database?

  • Re: Failed to delete mount path due to SIDB
    Posted: 10-19-2010, 10:47 AM


    Please make sure youhave update 17504 installed on the CS and then try this again. This patch was created to allow for removal of mount paths if the data is all aged and there are no references to data stored on that path.

    If that still fails I would suggest that you open a ticket so support can check this out as you may not want to deelte from the DB if there are some references to that drive in the DDB as it may cause issues there.

  • Re: Failed to delete mount path due to SIDB
    Posted: 10-19-2010, 3:57 PM


    Please make sure you have Service Pack 5 installed on the CommServe and MediaAgent(s).


  • Re: Failed to delete mount path due to SIDB
    Posted: 10-21-2010, 5:13 PM

    I already have SP 5 installed on everything. ;-/

  • Re: Failed to delete mount path due to SIDB
    Posted: 10-21-2010, 6:09 PM



    I would recommend contacting the Support Hotline and having a ticket opened for this. 



  • Re: Failed to delete mount path due to SIDB
    Posted: 10-22-2010, 8:21 AM


    To clarify,

    the patch is designed to allow a customer to remove the mount path after all the jobs and dedup references have aged off. When you right click on a mount path and select view content. This only show valid restorable jobs in the gui. what you dont' see is the deduplicated data that has been written to disk. You may data on this mount path that is being referenced by valid job on another mount path within the same library. This cross reference between mount paths is what is preventing you from deleting the lun.


  • Re: Failed to delete mount path due to SIDB
    Posted: 10-24-2010, 5:24 PM

    I've logged a call - they had me install a patch 18857 but it didn't make any difference. I've since uploaded my db so they can poke around.


    With regards to AaronA's last post - should that data that is left behind on the disk also be written to tape?  thats how all of my policies work so i would have thought that it'd just reference the tape.


    Also.. I found i had 3 SP's uing dedupe so i tried closing each ones dedupe store hoping that that would make it use the other luns for the data but 1 of the SP's failed to seal.  I'm wondering if maybe that SP has some corrupted reference in it thats causing the problem. 

  • Re: Failed to delete mount path due to SIDB
    Posted: 10-29-2010, 12:58 AM

    Based on what AaronA posted I tried an experiment.  I create new copies with the 3 SP's using dedupe.  I then promoted them to primary and deleted the old  primary.  I ran data aging and now i can delete the luns.


    This of course probably woudn't have work if i'd wanted to keep dedupe on these polices.  Hopefully v9 will make the invisible things dedupe leaves on luns a bit more visibile

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Copyright © 2020 Commvault | All Rights Reserved. | Legal | Privacy Policy