Media Agent Mount Path Failure, Aux Copy to the rescue?

Last post 12-16-2015, 12:02 PM by isle. 3 replies.
Sort Posts: Previous Next
  • Media Agent Mount Path Failure, Aux Copy to the rescue?
    Posted: 11-30-2015, 12:13 AM

    We have 3 identical MAs with a single library on each MA with 5 drive letters under each library.  Primary replicates to secondary and tertiary.  We're looking at the possibily of losing one of the drive letters on the secondary Media Agent.  All the jobs are on the primary MA, can we get the drive replaced/repaired and aux copy the missing jobs back over?  I know that what mount path it writes to isn't identical across each MA, but I'm guessing there has to be some built in logic for it to detect that the MA doesn't have all the pieces it needs for each backup job and request the job be sent from the other MA.  We have a single DDB per MA and all data backed up is deduplicated.  Thoughts?  Questions to help me clarify?

  • Re: Media Agent Mount Path Failure, Aux Copy to the rescue?
    Posted: 11-30-2015, 12:27 PM
    • isle is not online. Last active: 06-04-2019, 3:28 PM isle
    • Top 25 Contributor
    • Joined on 08-21-2012
    • NJ
    • Adept
    • Points 308

    The first thing I would do is run verification of deduplicated data with verification of existing jobs against the MP that has damage. This will take time to 0 out and corrupt jobs and no other jobs can run to the storage policy. 

     

    the aux copy if caught up, should have jobs ready to restore as well and if needed you could switch the primary copy and move back jobs on a needed basis.

    http://documentation.commvault.com/commvault/v10/article?p=features/deduplication/t_verifying_the_deduplicated_data.htm

  • Re: Media Agent Mount Path Failure, Aux Copy to the rescue?
    Posted: 12-15-2015, 10:21 AM

    We were successful in getting the MoveMountPath Workflow completed and move the data off the drive to a temp space before we encountered any problems.  Then we repaired things and used the workflow again to move everything back.  I'm doing a verification job now on all jobs just to be safe.  Going to take 4-5 days but that's ok.

  • Re: Media Agent Mount Path Failure, Aux Copy to the rescue?
    Posted: 12-16-2015, 12:02 PM
    • isle is not online. Last active: 06-04-2019, 3:28 PM isle
    • Top 25 Contributor
    • Joined on 08-21-2012
    • NJ
    • Adept
    • Points 308

    Excellent glad to hear it!

     

    Corruption is never fun

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy