AUX Copy streams & dwindling speeds

Last post 02-08-2016, 3:58 PM by isle. 2 replies.
Sort Posts: Previous Next
  • AUX Copy streams & dwindling speeds
    Posted: 12-17-2015, 11:03 AM

    All,

    We have an issue with AUX Copies driving our WAN to max (200Mbit/sec) but slowing down over time (as the number of streams decreases) and I am looking for suggestions before I escilate to support (if neccisary). Day 1, backups run nightly at 8:00 PM and create (for example) 100 new backup jobs. The AUX copy schedule fires at 10:00 PM and finds 100 new backups to transfer, and begins transfering them at max speed using 40-50 streams. However, as the number of active streams drops below 40, our throughput drops (this is expected). The problem is Day 2, backups fire at 8:00 PM, AUX copy fires at 10:00 PM with 100 new backups, but because Day 1 AUX copy is still running, it stays queued. Despite having the bandwidth, we will not drive 200Mbit/sec until the Day 1 AUX Copy completes, and the Day 2 AUX Copy fires with 100 new jobs to stream.

    Temporarily I am killing the Day 1 AUX Copy, which causes the Day 2 AUX Copy to fire. This AUX Copy then includes the last Day 1 stream and all Day 2 streams. The prefered behavior would be that when the  day 2 AUX copy fires, it simply adds those 100 streams to the existing transmission. Is there a setting for this somewhere? Other work arounds include #1 - automatically killing the job every X hours and #2 - breaking large streams into smaller streams (where possible).

    Many thank!

    -Jonathan

  • Re: AUX Copy streams & dwindling speeds
    Posted: 12-18-2015, 6:38 AM

    Hi Jonathan,

    I think, there is no way of including new jobs during the actual run of the Auxcopy job
    New jobs will be looked for and processed per default at the end of the current run

    You could, on the other hand, restrict the total running time of your auxcopy to 4hrs (or more) and restart the Auxcopy every 4hrs (or more) 
    The new auxcopy job will than include the new backups immediately.

    No manual kill of running auxcopies needed.
    The parameter can be defined in "advanced auxcopy job options -> job retry"

    another option can be (depends on the agents you use) to modify SP settings to "distribute data evenly among multiple streams for offline reads"

    This will fill up the streams in your SP evenly so the copy will need to copy maximum number of streams for a longer time (more performance during auxcopy)

    regards
    Klaus 

  • Re: AUX Copy streams & dwindling speeds
    Posted: 02-08-2016, 3:58 PM
    • isle is not online. Last active: 06-04-2019, 3:28 PM isle
    • Top 25 Contributor
    • Joined on 08-21-2012
    • NJ
    • Adept
    • Points 308

    are you on v10?

     

    http://docs.commvault.com/commvault/v10/article?p=features/performance_tuning/tunable_parameters.htm#Auxiliary_Copy

     

    Use Dynamic Stream Allocation feature to increase the rate of data transfer by distribute backup data evenly across available streams. For more information, refer to Performing Auxiliary Copy With Dynamic Stream Allocation.

     

     

     

    You could also set the job to not pick new jobs thus completing then the next automatic copy would see the 100 jobs+ and start fresh

     

     

    http://docs.commvault.com/commvault/v10/article?p=features/auxiliary_copy/aux_copy_adv.htm

    http://docs.commvault.com/additionalsetting/details?name=%22AUXCOPY_NOT_PICK_NEW_BACKUPS%22&id=29

    Preventing an Ongoing Backup Data from Being Copied

    Auxiliary Copy operations copy all eligible data, even from backup that have finished after the auxiliary copy operation has started. Auxiliary Copy operations can be prevented from copying this new data by configuring the AUXCOPY_NOT_PICK_NEW_BACKUPS additional setting. This is applicable if you have upgraded from the previous version of Simpana .

    Use the following steps to prevent the ongoing backup data from being copied:

    1. From the CommCell Browser, right-click the <CommServe node> and then click Properties.
    2. Click the Additional Settings tab.
    3. Click Add.
    4. In the Name box, type AUXCOPY_NOT_PICK_NEW_BACKUPS.
    5. In the Category list, select CommServe.
    6. In the Type list, select INTEGER.
    7. In the Value field, type 1.
    8. Click OK.
The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy