Quick Recovery setup problems

Last post 12-24-2010, 4:34 AM by GCattInUK. 7 replies.
Sort Posts: Previous Next
  • Quick Recovery setup problems
    Posted: 12-02-2010, 5:11 AM

    I’m trying to get Quick Recovery working on CV 8.  I want to take an iSCSI LUN, presented out from a NetApp filer, and create a snapshots of it and mirror it to a remote filer.

    I’m following this documentation http://documentation.commvault.com/commvault/release_8_0_0/books_online_1/english_us/prod_info/qr.htm

    I think I’ve installed the relevant products, but when I try to create a subclient under the QR Agent I can’t select any content.

    There is an empty box and buttons called Add Volume, Add App and Detect.

    Detect is the only one that does anything, it brings up Volume Explorer, which does display things, but whatever you do nothing appears in the original window.

     

    The QR Agent has an Authentication tab, I’ve tried adding a domain user, and the ndmp user, but neither display any more than having nothing in the Authentication tab!

     

    Ideas anyone?

  • Re: Quick Recovery setup problems
    Posted: 12-03-2010, 10:31 AM

    With the advent of SnapProtect, the QR product only applied to a very specific niche (you might want to check out the SnapProtect documentation below to see if it better fits your needs)

    In any event if you need to proceed with QR, when you did the "detect volumes" did you select the "detect volumes on netapp file server" which has a drop down for the filer in question? 

     

    http://documentation.commvault.com/commvault/release_8_0_0/books_online_1/english_us/features/snap_backup/snap_backup.htm

  • Re: Quick Recovery setup problems
    Posted: 12-03-2010, 1:16 PM

    I've had a look at SnapProtect, but that doesn't seem to allow me to trigger NetApp's SnapMirror to a second filer.

    Unless, of course, you know different...

  • Re: Quick Recovery setup problems
    Posted: 12-13-2010, 3:10 PM

    Hi GCatt,

    Some things on this:

    1) Make sure you are following the steps Specific to your setup.  IF you navigate the QR Docs ( http://documentation.commvault.com/commvault/release_8_0_0/books_online_1/english_us/prod_info/qr.htm ) then go to Snapshot Management -> Netapp -> (appropriate config).  There are specific setups for Snapmirror / Snapvault, ect so the correct enablers need to be installed.

    2) Setup the account that can access the Filer in the GUI (typically the root accout).

    3) Go to the Control Panel -> Volume Explorer.  Right Click on the client with QR Agent and the Snap enabler installed and do a Detect.  A "Select Detection Host" window will come up.  Hit the button for "Detect volumes on the Netapp File Server", and select the filer.

    This should populate volume explorer with the volumes on the netapp, and afterwich you should be able to add to subclient content.

    Ted

  • Re: Quick Recovery setup problems
    Posted: 12-21-2010, 11:09 AM

    I've followed the documentation you mentioned, so that bit should be fine.

    Thanks for clarifying which account to use, I've tried several different ones!

    I have made some progress: it seems to work best if you Browse the filer at the earliest opportunity, then when you try to add volumes later it seems to work more reliably.

    I'm now getting somewhere, I can try to create the snap mirror Cool, but it fails three different ways Cry

    1. If you create the volumes then restrict the destination volume (as instructed) it fails in CopyMgrSnapMirror.log as if there is no space on the destination (CVRecoveryVolume::FindFreeVolFromScratchPoolForSrc() - Skipping destination:[110] it does not have enough space for source:[26]. Destination has avalailable:[0] and source has total:[83886080])
    2. If you get rid of the destination volume restriction it complains it isn’t restricted in CopyMgrSnapMirror.log (NDMP Log Message:[2][destination must be restricted for an initial transfer])
    3. If you do the initial replication from NetApp, so the mirror pair relationship is already set up, and then try to trigger another snapmirror this fails in SANVolCopy.log CVRecoveryVolume::FindFreeVolFromScratchPoolForSrc() - Skipping destination:[110] it does not have enough space for source:[26]. Destination has avalailable:[83619840] and source has total:[83886080])

    It doesn’t matter what size the destination volume is, the snap never fits.

  • Re: Quick Recovery setup problems
    Posted: 12-21-2010, 11:43 AM

    Item 1 - this seems to not be able to stat the destination volume to get free space so it fails.

    Item 2  - sounds like it not using the correct volume, thus states it cannot be locked and accept data transfer.

     item 3 - What is the total size of the source volume and total size of the destination volume?  Since its replication the destination TOTAL size needs to be larger.  Free space may be irrelevant this early in the job.

    IF your source volume is 1 TB and only has 100 gig on it the destination needs to be ~1.01 TB, even though we only need 100 gig worth of space.

     

     

  • Re: Quick Recovery setup problems
    Posted: 12-21-2010, 11:59 AM

    GCatt,

    I'm pretty sure you have to do things as you have in Step 1 above, setup the destination volume and make sure its set to restricted for this to work.

    It looks like there is some issue with us detecting the size of the restricted volume since the error shows that we see the size as 0 - "Destination has avalailable:[0] and source has total:[83886080]"

    This may be some timing issue, you may want to detect the volume first and add it to the scratch pool (so it sees the correct size) and then set it to restricted on the filer.

    If that doesnt work, try this in reverse order, setup the volume and restrict it, then detect and add it to the scratch pool.

    Ted

  • Re: Quick Recovery setup problems
    Posted: 12-24-2010, 4:34 AM

    You seem to have identified the problem, thank you.

    The source and target volumes were exactly the same size.

    I created a new target that was 2.5x the size of the source, set it all up again including making the target restricted and then it worked! Incidentally increasing the size of the original destination volume didn't work - but using a new volume did.

    I need to do some more testing to make sure it wasn't a fluke, but at least now I'm heading in the right direction.

    Thanks to everyone for their suggestions, Merry Christmas and Happy New Year!

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy