Intellisnap ORACLE cannot rename snapshot at ASM level

Last post 03-09-2017, 11:36 AM by dsegura980. 0 replies.
Sort Posts: Previous Next
  • Intellisnap ORACLE cannot rename snapshot at ASM level
    Posted: 03-09-2017, 11:36 AM

    Hello all

    I hope you can help me to identify what is not working here when trying to make a backup using Intellisnap in ORACLE

    I am using SIMPANA 11 SP5+, Media-Agents are on RHEL as well as the ORACLE databases. I am able to succesfully snapshot the data but when it comes to make a backup out of it the ASM fails.

    I can see the files mounted on the 3PAR array, then on the host as raw devices and finally on /opt/commvault/MediaAgent/SnapVolumeMounts... it is when ASM tries to mount the actual data when it fails... the error message is as follows:

    2216 8e0  03/09 16:26:44 202211 virtual CQiError CVSnapOSUtilUNIX::mountVolumes(SMMetaDataInfo&, std::vector<SMVolumeInfo, std::allo Mounting raw device:/dev/mpath/350002ac39aaa224fp1: for volume id:-1:
    2216 8e0 03/09 16:26:44 202211 CVSnapOSUtilUNIX::mountVolumes() - setting SM_VS_MNT_MOUNTED for volume -1
    2216 8e0 03/09 16:26:44 202211 virtual CQiError CVSnapOSUtilUNIX::mountVolumes(SMMetaDataInfo&, std::vector<SMVolumeInfo, std::allo Successfully mounted (/dev/mpath/350002ac39aaa224fp1 -> /opt/commvault/MediaAgent/SnapVolumeMounts/SnapMnt_1_2_510313_74_1) RP()
    2216 8e0 03/09 16:26:44 202211 virtual CQiError CVSnapOSUtilUNIX::mountVolumes(SMMetaDataInfo&, std::vector<SMVolumeInfo, std::allo Mounting raw device:/dev/mpath/350002ac39aac224fp1: for volume id:-2:
    2216 8e0 03/09 16:26:44 202211 CVSnapOSUtilUNIX::mountVolumes() - setting SM_VS_MNT_MOUNTED for volume -2
    2216 8e0 03/09 16:26:44 202211 virtual CQiError CVSnapOSUtilUNIX::mountVolumes(SMMetaDataInfo&, std::vector<SMVolumeInfo, std::allo Successfully mounted (/dev/mpath/350002ac39aac224fp1 -> /opt/commvault/MediaAgent/SnapVolumeMounts/SnapMnt_1_2_510313_74_2) RP()
    2216 8e0 03/09 16:26:45 202211 virtual CQiError CVSnapOSUtilUNIX::mountVolumes(SMMetaDataInfo&, std::vector<SMVolumeInfo, std::allo Mounting raw device:/dev/mpath/350002ac39aae224fp1: for volume id:-3:
    2216 8e0 03/09 16:26:45 202211 CVSnapOSUtilUNIX::mountVolumes() - setting SM_VS_MNT_MOUNTED for volume -3
    2216 8e0 03/09 16:26:45 202211 virtual CQiError CVSnapOSUtilUNIX::mountVolumes(SMMetaDataInfo&, std::vector<SMVolumeInfo, std::allo Successfully mounted (/dev/mpath/350002ac39aae224fp1 -> /opt/commvault/MediaAgent/SnapVolumeMounts/SnapMnt_1_2_510313_74_3) RP()
    2216 8e0 03/09 16:26:45 202211 CVSnapOSUtil::mountVolumes() - Volume (-1) mount status is 59 RemOp:120-4
    2216 8e0 03/09 16:26:45 202211 CVSnapOSUtil::mountVolumes() - Volume (-2) mount status is 59 RemOp:120-4
    2216 8e0 03/09 16:26:45 202211 CVSnapOSUtil::mountVolumes() - Volume (-3) mount status is 59 RemOp:120-4
    2216 8e0 03/09 16:26:45 202211 CVSnapOSUtilASM::LoadOSLVMMetaData(2913) - From Snap OS Util VolSnap:Status-[0] Err-[0:].
    2216 8e0 03/09 16:26:45 202211 CVSnapOSUtilASM::DoASMOperation(3958) - unable to perform asm specific operation: renameASMDiskGroup failed during snap verification
    2216 8e0 03/09 16:26:45 202211 CVSnapOSUtilASM::mountVolumes(1556) - unable to perform asm specific operation: Mount failed, error=unable to perform asm specific operation: renameASMDiskGroup failed during snap verification (MM.60608)
    2216 8e0 03/09 16:26:45 202211 CVMASnapHandlerInternal::mountVolumes() - Failed with error [-1005742608:].
    2216 8e0 03/09 16:26:45 202211 CVMASnapHandlerInternal::mountVolumes() - Failed to mount volumes from snap devices. Err [-1005742608:].
    2216 8e0 03/09 16:26:45 202211 CVMASnapHandlerInternal::mountVolumes() - Request for mountVolumes Failed. Status [-1].
    2216 8e0 03/09 16:26:45 202211 WORKER [12705455/0/0 ] Failed to Mount Volume . Err [60611:Failed to rename mounted snap ASM DiskGroup].
    2216 8e0 03/09 16:26:45 202211 WORKER [12705455/0/0 ] ProcessVolSnapMount from completed
    2216 9a4 03/09 16:26:46 202211 SERVICE [12705593/0/0 ] Received CVMA_VOL_SNAP_OPERATION_REQ
    2216 11ea 03/09 16:26:46 202211 CVMASnapHandlerInternal::initialize() - Request[12705593] for CVMASnapHandlerInternal::unmountVolumes - Job[202211] CCId[2].
    2216 11ea 03/09 16:26:46 202211 CVMMSnapAPI::updateVolumeSnaps() - Completed the updateVolumeSnaps operation.
    2216 11ea 03/09 16:26:46 202211 CVMMSnapAPI::updateVolumeSnaps() - Completed the updateVolumeSnaps operation.
    2216 11ea 03/09 16:26:46 202211 InitializeASMSpecificParameters(3665) - locking OSUTILASM_OPERATION mutex(timeOut=3600000)
    2216 11ea 03/09 16:26:46 202211 CVSnapOSUtilASM::selectAndUnmountASMDiskGroupVolumesForPrepareRevertOrUnmount(4573) - DiskGroup [+COMMVAULT_DATA] already unmounted
    2216 11ea 03/09 16:26:46 202211 virtual CQiError CVSnapOSUtilUNIX::unmountVolumes(SMMetaDataInfo&, std::vector<SMVolumeInfo, std::al Successfully unmounted (/dev/mpath/350002ac39aaa224fp1 -> /opt/commvault/MediaAgent/SnapVolumeMounts/SnapMnt_1_2_510313_74_1)
    2216 11ea 03/09 16:26:46 202211 virtual CQiError CVSnapOSUtilUNIX::unmountVolumes(SMMetaDataInfo&, std::vector<SMVolumeInfo, std::al Successfully unmounted (/dev/mpath/350002ac39aac224fp1 -> /opt/commvault/MediaAgent/SnapVolumeMounts/SnapMnt_1_2_510313_74_2)
    2216 11ea 03/09 16:26:46 202211 virtual CQiError CVSnapOSUtilUNIX::unmountVolumes(SMMetaDataInfo&, std::vector<SMVolumeInfo, std::al Successfully unmounted (/dev/mpath/350002ac39aae224fp1 -> /opt/commvault/MediaAgent/SnapVolumeMounts/SnapMnt_1_2_510313_74_3)
    2216 11ea 03/09 16:26:46 202211 CVSnapOSUtilASM::LoadOSLVMMetaData(2913) - From Snap OS Util VolSnap:Status-[0] Err-[0:].
    2216 11ea 03/09 16:26:46 202211 CVMMSnapAPI::updateVolumeSnaps() - Completed the updateVolumeSnaps operation.
    2216 11ea 03/09 16:26:46 202211 CVMASnapHandlerInternal::removeMountPathFolder() - Empty Mount folder [] for VolumeId [740] - skipping Mount Folder removal...
    2216 11ea 03/09 16:26:46 202211 CVMMSnapAPI::updateVolumeSnaps() - Completed the updateVolumeSnaps operation.
    I tried a number of things to make this work unsuccesfully, I followed the configuration manual on every step but it sems is still failing.
    Any ideas?
     
    Cheers guys!!
The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy