Error while create backup VMWARE over SAN

Last post 01-18-2011, 6:01 PM by jdownes. 10 replies.
Sort Posts: Previous Next
  • Error while create backup VMWARE over SAN
    Posted: 01-06-2011, 6:55 AM

     I try make backup VM over SAN in Simpana9 SP1 and get error

      CVMDiskInfo::Dispatch_VixDiskLib_Connect() - VixDiskLib_Connect failed Err=3 One of the parameters was invalid

    I using VDDK 1.1.1 and 1.2.1 with same result.

     

    ### Createsnapshot --- Successfully created Snapshot __GX_BACKUP__ snapshot-2984 from VM RSA
      CVMWareInfo::_MountVM_VCB4() - Connecting to VM [RSA] config [[EMC-GB-10] RSA/RSA.vmx] MoRef [vm-2595] snapshot [snapshot-2984] for disk access
      CVMDiskInfo::Connect() - Selecting transport mode: san
      CVMDiskInfo::_VixDiskLibThread() - Calling VixDiskLib_Connect for thread 6c4
      CVMDiskInfo::_VixDiskLibThread() - Completed VixDiskLib_Connect for thread 6c4
      CVMDiskInfo::Dispatch_VixDiskLib_Connect() - VixDiskLib_Connect failed Err=3 One of the parameters was invalid
      CVMWareInfo::MountVM() - MountVM_VCB4() failed!!
      CVMWareInfo::_UnmountVM_VCB4() - Unmounting Disks for VM [RSA]
      CVMWareInfo::_UnmountVM_VCB4() - Removing Snapshot of VM [RSA] Guid [42091466-971f-6077-1d6d-1b0c8761c409]
     ### RemoveSnapshot --- Removing Snapshot __GX_BACKUP__ snapshot-2984 from VM RSA
      vsbkp::CheckVMInfoError() - VM [RSA] Error connecting to Virtual Machine.
      CVMWareInfo::_UnmountVM_VCB4() - Unmounting Disks for VM [RSA]
      vsbkp::HandleVMComplete() - Skipped VM [RSA]
      vsbkp::Wait() - Done processing VM RSA - SKIPPED
      vsbkp::BackupAllVM() - Closing archive file for backup object 0
      vsArchive::close() - Closing archive file...
      CCVAPipelayer::CloseArchiveFile() - Closing archive file[afilenum=34] in BACKUP

     

    Any ideas?

  • Re: Error while create backup VMWARE over SAN
    Posted: 01-06-2011, 8:36 AM

    What OS is the RSA VM and what type of disks are attached to this machine (are they vRDM, pRDM, independent?

  • Re: Error while create backup VMWARE over SAN
    Posted: 01-06-2011, 9:04 AM

    Also make sure that you present the LUNS that your VM's are located on to the Proxy (Server with the Virtual Server iDA installed)

     

    These will show up in Disk Management with no drive letter and will be marked as offline.

     

    As a test you could also test backing up the VM using the auto method instead of selecting the san method to verify you can connect and back it up. The auto method will try san first then will try nbd (Network Mode) as a failback method.


    Client Team Supervisor - Focus on Virtualization
    Follow me on Twitter - @wfarinella
  • Re: Error while create backup VMWARE over SAN
    Posted: 01-06-2011, 9:07 AM
    • mort is not online. Last active: 01-13-2016, 10:37 AM mort
    • Top 50 Contributor
    • Joined on 07-06-2010
    • Patrick
    • Adept
    • Points 209

    Using the vddk, you shouldn't have to present the luns to the VSA, at least that's my understanding.

    If you are doing this on a Windows Server please remember to run diskpart automount disable on the VSA to stop windows writing a signature to these LUNs, and assign them read-only.

     

  • Re: Error while create backup VMWARE over SAN
    Posted: 01-06-2011, 6:19 PM

    Couple of things in response to posts above.

    We use VADP and you still have to present the LUNs to the MA.

    Setting it to auto for us meant it used VCB which was slow, we had to set the menu option to be SAN to get the reasonable speed back.

  • Re: Error while create backup VMWARE over SAN
    Posted: 01-07-2011, 5:56 AM
    • mort is not online. Last active: 01-13-2016, 10:37 AM mort
    • Top 50 Contributor
    • Joined on 07-06-2010
    • Patrick
    • Adept
    • Points 209

    sssstew:

    Couple of things in response to posts above.

    We use VADP and you still have to present the LUNs to the MA.

    Setting it to auto for us meant it used VCB which was slow, we had to set the menu option to be SAN to get the reasonable speed back.

    No you don't have to present the LUNs, we don't present the luns to our VSA proxies, and they still use VADP to perform backups I can post logs to prove this is the case, the only drawback is that they are obviously LAN based, but seen as we have dedicated 10Gb LAN between the VSA and VMware cluster, we took the decision that it's safer to not present the LUNS to the VSA proxies.

  • Re: Error while create backup VMWARE over SAN
    Posted: 01-08-2011, 9:33 PM
    Vincenzo_Basolino:

    What OS is the RSA VM and what type of disks are attached to this machine (are they vRDM, pRDM, independent?

  • Re: Error while create backup VMWARE over SAN
    Posted: 01-09-2011, 9:40 PM

    Vincenzo_Basolino:

    What OS is the RSA VM and what type of disks are attached to this machine (are they vRDM, pRDM, independent?

    Media Agent Win 2k8R2

    RSA WM Win 2k8R2 - disk as datastore VMWare, not RDM

  • Re: Error while create backup VMWARE over SAN
    Posted: 01-09-2011, 9:41 PM

    mort:

    Using the vddk, you shouldn't have to present the luns to the VSA, at least that's my understanding.

    If you are doing this on a Windows Server please remember to run diskpart automount disable on the VSA to stop windows writing a signature to these LUNs, and assign them read-only.

     

    Already set, without result.

  • Re: Error while create backup VMWARE over SAN
    Posted: 01-10-2011, 3:56 AM

    One problem is resolved.

    I replace Virtual Center authorization to ESX authorization in Virtual Server. But get other error

    3168 a14 01/10 14:43:54 ### SAN: Cannot access a SAN/iSCSI LUN backing this virtual disk. (Hint: If you are using vcbMounter you can use the option "-m nbd" to switch to network based disk access if this is what you want.) If you were attem
    pting file-level access, stop the vmount Service by typing "net stop vmount2" on a command prompt to force vmount to re-scan for SAN LUNs and re-try the command.
    3168 a14 01/10 14:43:54 ### DISKLIB-LINK  : "san://544-snapshot-80[EMC-GB-10] RSA/RSA-000001.vmdk@esx-gb-ibm-bl05.hq.bc?root/XXX" : failed to open (You do not have access rights to this file).
    3168 a14 01/10 14:43:54 ### DISKLIB-CHAIN : "san://544-snapshot-80[EMC-GB-10] RSA/RSA-000001.vmdk@esx-gb-ibm-bl05.hq.bc?root/XXX" : failed to open (You do not have access rights to this file).
    3168 a14 01/10 14:43:54 ### DISKLIB-LIB   : Failed to open 'san://544-snapshot-80[EMC-GB-10] RSA/RSA-000001.vmdk@esx-gb-ibm-bl05.hq.bc?root/XXXXX' with flags 0x1e You do not have access rights to this file (3390).

    I connect as root - superadministrator. How I can check access to snapshot?

  • Re: Error while create backup VMWARE over SAN
    Posted: 01-18-2011, 6:01 PM

    Try creating a local Windows user account on the VSA server called "root" with the same password as the root user on ESX.

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy