Backup Client installation on a mac

Last post 06-19-2018, 8:09 AM by winklerd. 4 replies.
Sort Posts: Previous Next
  • Backup Client installation on a mac
    Posted: 06-13-2018, 10:10 AM

    Hi,

     

    i have some problems to install the backup client to my apple server.

     

    Server Software Version: Commvault 11 SP11

     

    Mac: 10.10.5

     

    I disabled firewall on both mac and commvault cell. Also I enabled the root user on the mac, but I cannot not push the client to the mac from the administration center.

     

    Here are the log files.

     

    8744  3394  06/13 15:20:45 1427 JOB MANAGER INPUT PARAMETERS

    8744  3394  06/13 15:20:45 1427     Hostname (mangled) : CommvaultServer* *8400

    8744  3394  06/13 15:20:45 1427     DelayedReboot                      : [NO]

    8744  3394  06/13 15:20:45 1427     AutoReboot                            : [NO]

    8744  3394  06/13 15:20:45 1427     Restart                                               : [NO]

    8744  3394  06/13 15:20:45 1427     JobId                                      : 1427

    8744  3394  06/13 15:20:45 1427     TaskId                                    : 298

    8744  3394  06/13 15:20:45 1427     JMToken                                            : 1427:2:1

    8744  3394  06/13 15:20:45 1427     IgnoreRunningJobs    : [YES]

    8744  3394  06/13 15:20:45 1427     Job Type                                : Install Software

    8744  3394  06/13 15:20:46 1427 Init() - Initializing job control [token=1427:2:1,cn= ], serverName [Instance001], ControlFlag [1], Job Id [1427]

    8744  3394  06/13 15:20:47 1427 CVJobCtrlLog::registerProcess(): successfully created file [C:\Program Files\Commvault\ContentStore\Base\JobControl\8.744]

    8744  3394  06/13 15:20:47 1427 GetIsUsingNewDownload() - Use New Download key is set to [true]

    8744  3394  06/13 15:20:47 1427 --------------------------------------------------------------

    8744  3394  06/13 15:20:47 1427 ------------- Starting Install Software -------------

    8744  3394  06/13 15:20:47 1427 --------------------------------------------------------------

    8744  3394  06/13 15:20:47 1427 [GetOptionsFromGui]() - Xml request received from GUI <?xml version='1.0' encoding='utf-8' ?><TMMsg_JobOption><adminOpts><clientInstallOption useSSHKey="0" useSSHKeyPassphrase="0" reuseADCredentials="0" installOSType="1" sshPortNumber="" discoveryType="0" useSSHNCPortNumber="0"><installerOption requestType="0" Operationtype="0" CommServeHostName=" " RemoteClient="0"><CommServeInfo/><installFlags skipConfigureMigrationAssistant="0" unixGroup="" unixGroupAccess="7" allowMultipleInstances="0" autoInstallPassiveNodes="0" numberOfStreams="0" skipConfigureLaptopBackupMonitor="0" restoreOnlyAgents="0" install32Base="0" patchStandbyCS="0" unixTempDirectory="" unixOtherAccess="5" advancedOptions="" stopOracleServices="0" autoRebootPassiveNodes="0" singleInterfaceBinding="0" skipClientsOfCS="0" skipConfigureProcessManager="0" ignoreJobsRunning="1" hideApps="0" forceReboot="0" overrideClientInfo="1"><firewallInstall httpProxyConfigurationType="0" proxyClientName="" enableFirewallConfig="0" firewallConnectionType="0" proxyHostName="" portNumber="0"/></installFlags><User userName="domain\user" userId="6"/><clientComposition activateClient="1" packageDeliveryOption="0" overrideSoftwareCache="0"><components><sqlAgent instanceAutoDiscovery="1"/><commonInfo globalFilters="2"><storagePolicyToUse/></commonInfo><exchangeDatabase differentialBackup="0"/><contentIndexingEngine/><fileSystem configureForLaptopBackups="0"><selectedSubclientPolicy/></fileSystem><mediaAgent/><componentInfo postInstallCommand="" _type_="60" installCommand="" unInstallCommand="" osType="Unix" ComponentName="File System Core" consumeLicense="1" ComponentId="1002" clientSidePackage="1"/></components><sharedInstallLocation silServerID="0"/><clientRoles bNetworkProxy="0" bLaptopBackup="0"/><clientInfo><clientProps/><client cvdPort="0"/></clientInfo></clientComposition></installerOption><clientDetails><clientEntity clientName="172.20.5.113" commCellId="0" clientId="163"/></clientDetails><clientAuthForJob password="||#05!MzRmNWM3ZGU3MDU4YzE5N2JhMThhODUxOGViNDNiYmFm" userName="admin"/></clientInstallOption><updateOption invokeLevel="5"/></adminOpts><restoreOptions><virtualServerRstOption isBlockLevelReplication="0"/></restoreOptions></TMMsg_JobOption>

    8744  3394  06/13 15:20:47 1427 Packages selected For Install :File System Core

    8744  3394  06/13 15:20:47 1427 CommServe Cache Location [C:\Program Files\Commvault\ContentStore\SW]

    8744  3394  06/13 15:20:47 1427 GetIsUsingNewDownload() - Use New Download key is set to [true]

    8744  3394  06/13 15:20:47 1427 [SetCSCacheInfo]() - Trying to move to side by side cache.

    8744  3394  06/13 15:20:47 1427 [TransitToNewDownload]() - Staging folder [C:\Program Files\Commvault\ContentStore\SW\CVMedia-Staging\11.0.0\Windows] does not exist, checking regular cache

    8744  3394  06/13 15:20:47 1427 [TransitToNewDownload]() - Regular cache [C:\Program Files\Commvault\ContentStore\SW\CVMedia\11.0.0\Windows] is also empty, skipping the transition.

    8744  3394  06/13 15:20:47 1427 [getThreadPoolCount] Initializing thread pool size : 5

    8744  3394  06/13 15:20:47 1427 Thread pool monitor interval [300] seconds, Refresh interval [60] seconds

    8744  3394  06/13 15:20:47 1427 [ComputeRequiredRelAndOsList]() - Could not get answer file since install directory is empty for client [172.20.5.113].

    8744  3394  06/13 15:20:47 1427 [ComputeRequiredRelAndOsList]() - Successfully launched thread with Id [1] for [172.20.5.113] to get it's binaryset name.

    8744  3394  06/13 15:20:47 1427 [ComputeRequiredRelAndOsList]() - Waiting for all the clients threads to complete..

    8744  4798  06/13 15:20:47 1427 GetRemoteProcessorType() - SSH port is set to [], key file path is [], use passphrase [false]

    8744  4798  06/13 15:20:48 1427 GetRemoteProcessorType() - Unable to login to remote machine [172.20.5.113] with error [FATAL ERROR: Network error: Connection refused

     

    ], please check the remote machine host name and login details.

    8744  4798  06/13 15:20:48 1427 [GetClientOSType]() - Failed to compute the binary set name of client [172.20.5.113].

    8744  3394  06/13 15:20:48 1427 ::GetServicePackInstalledOnClient() - Could not find sCUName in registry

    8744  3394  06/13 15:20:48 1427 [CheckAndDownloadRequiredMedia]() - Download is not required.

    8744  3394  06/13 15:20:48 1427 [ReadPackageDetails] Packages.xml location C:\Program Files\Commvault\ContentStore\SW\CVMedia\11.0.0\SP11_1114128_R463\Windows\WinPackages.xml

    8744  3394  06/13 15:20:48 1427 [getXMLDetails]() - Get XML details from [C:\Program Files\Commvault\ContentStore\SW\CVMedia\11.0.0\SP11_1114128_R463\Windows\WinPackages.xml] with input: [C:\Program Files\Commvault\ContentStore\SW\CVMedia\11.0.0\SP11_1114128_R463\Windows\WinPackages.xml] isBinaryXML [NO]

    8744  3394  06/13 15:20:48 1427 [getXMLDetails]() - Get XML details from [C:\Program Files\Commvault\ContentStore\SW\CVMedia\11.0.0\SP11_1114128_R463\Windows\BinaryInfo.xml] with input: [C:\Program Files\Commvault\ContentStore\SW\CVMedia\11.0.0\SP11_1114128_R463\Windows\] isBinaryXML [YES]

    8744  3394  06/13 15:20:49 1427 [ReadPackageDetails] Packages.xml location C:\Program Files\Commvault\ContentStore\Base\pkg.xml

    8744  3394  06/13 15:20:49 1427 [getXMLDetails]() - File [C:\Program Files\Commvault\ContentStore\Base\pkg.xml] is not present.

    8744  3394  06/13 15:20:49 1427 [ReadPackageDetails] Get XML details returns [false], osId [-1] and file path [C:\Program Files\Commvault\ContentStore\Base\pkg.xml], isWindows [false]

    8744  3394  06/13 15:20:49 1427 [ReadPackageDetails]() - Failed to read Unix Package Details.Exiting...

    8744  3394  06/13 15:20:49 1427 [InitGlobals]() - Failed to read the package details

    8744  3394  06/13 15:20:49 1427 [InitGlobals]() - Continuing to attempt the clients for which media is available.

    8744  3394  06/13 15:20:49 1427 Only remote cache's having status as invalid will be tried for sync.

    8744  3394  06/13 15:20:49 1427 [SyncUAForJob]() - Remote cache list is empty for the syncup.

    8744  3394  06/13 15:20:49 1427 Number of clients in job: [1]

    8744  3394  06/13 15:20:49 1427 Created lock file [C:\Program Files\Commvault\ContentStore\Deployment\SwCacheLocks\ \ReadLocks\P8744_J1427.lock]

    8744  3394  06/13 15:20:49 1427 Rights for user domain\user(6) are OK

    8744  3394  06/13 15:20:49 1427 Use updated binary set id [1] for client id [163]

    8744  3394  06/13 15:20:49 1427 SimInstalledPackages does not contain any entries for clientId [163]

    8744  3394  06/13 15:20:49 1427 Client does not have any physical package.Client should be treated as new.

    8744  3394  06/13 15:20:49 1427 [GetClientInfo]() - Getting associated (phy/vir) clients and their package list for client [163]

    8744  3394  06/13 15:20:49 1427

    8744  3394  06/13 15:20:49 1427  ******      Client = [172.20.5.113], ClientId = [163], Release = [11.0.0], UpdateAgentClientId = [2]    

    8744  3394  06/13 15:20:49 1427 Binary set id [1], SimOS id [20], [updateOsId : Windows]

    8744  3394  06/13 15:20:49 1427 [SetIsAgentlessClient]() - This is a pre-configured client [163], No physical packages present.

    8744  3394  06/13 15:20:49 1427 [CheckIfInstallRequired]() - It is a pre install. New client will be installed..

    8744  3394  06/13 15:20:49 1427 It seems Client is locally uninstalled. Reading client's display name and network hostname from app_client table and ignoring name set in XML blob from GUI

    8744  3394  06/13 15:20:49 1427

    8744  3394  06/13 15:20:49 1427  ******      New Client = [172.20.5.113], ClientId = [163], Release = [11.0.0], UpdateAgentClientId = [2]    

    8744  3394  06/13 15:20:49 1427 Client [172.20.5.113] cache source : CommServe

    8744  3394  06/13 15:20:49 1427 No package or update requires reboot as per info on CS, client can reboot (if required) during actual installation

    8744  3394  06/13 15:20:49 1427 [InstallBasePackageOnUnixClient]() - Answer file is [C:\Program Files\Commvault\ContentStore\Deployment\Install\172.20.5.113.base.xml].

    8744  3394  06/13 15:20:49 1427 Sending request to software cache [CommvaultServer] to perform base package install on remote client 172.20.5.113

    8744  3394  06/13 15:20:49 1427 [fnCSUpdateDBJMStatusNew]() - Client status [ QINSTALL_UPLOAD_IN_PROGRESS] set successfully in JMQinetixUpdateStatus Table  for client [ 163] [ 172.20.5.113 ]

    8744  3394  06/13 15:20:49 1427 [CCVPatchesUpdateDBServer::dllConnect]() - Starting dll connect in DBServer remoteHostName = CommvaultServer* *8400

    8744  3394  06/13 15:20:49 1427 [CCVPatchesUpdateDBServer::processXMLMessage] Requested Operation on Client succeeded

    8744  3394  06/13 15:20:49 1427 Successfully sent base package install request to client to software cache [CommvaultServer]

    8744  3394  06/13 15:20:49 1427 Successfully initiated base package install request for client [172.20.5.113]

    8744  3394  06/13 15:20:49 1427

    8744  3394  06/13 15:20:49 1427 ******   Now Check status of all clients   ******

    8744  3394  06/13 15:21:49 1427 Waiting for the remote cache syncup threads to be completed..

    8744  3394  06/13 15:21:49 1427 Clients Failed:

    8744  3394  06/13 15:21:49 1427 Client [163] [172.20.5.113] [QINSTALL_ERROR_LOGON]

    8744  3394  06/13 15:21:49 1427 *******************************************

    8744  3394  06/13 15:21:49 1427 bvSuccess = false, bvFailed = true, bvRestartNeeded = false, bvUnknown = false, bvOperationNotSupported = false, bvSkipped = false, bvPartialSuccess = false m_nvJobRetStatus = 1

    8744  3394  06/13 15:21:49 1427 Job Failed.

    8744  3394  06/13 15:21:49 1427 COMPLETE CALLED (JOB Status::FAIL), Job ID = 1427

    8744  5888  06/13 15:21:49 1427 CVJobCtrlLog::unregisterProcess(): successfully removed file [C:\Program Files\Commvault\ContentStore\Base\JobControl\8.744]

    8744  3394  06/13 15:21:49 1427 [deleteLockFiles]() - Successfully deleted the lock file C:\Program Files\Commvault\ContentStore\Deployment\SwCacheLocks\ \ReadLocks\P8744_J1427.lock

     

     

    Can I install the client manually by my own on the mac? Where are the files to find?

     

     

    Thanks for your help.

    Daniel

     

  • Re: Backup Client installation on a mac
    Posted: 06-18-2018, 5:35 PM

    You can do a local installation. Files you need will be in the software cache - http://documentation.commvault.com/commvault/v11/article?p=2718.htm

  • Re: Backup Client installation on a mac
    Posted: 06-19-2018, 3:01 AM

    Hi,

    i managed to install successfully the client first locally with the package from the software cache. The client get registered on the commserv and I installed the file server agent from the console with success. The problem now is, I cannot make a backup of the client, because there is only the defaultBackupSet and I am not able to create a new subclient?

    One the client everything looks fine, the services are up and running.

     

    Thanks for the help.

    Daniel

  • Re: Backup Client installation on a mac
    Posted: 06-19-2018, 7:52 AM

    Hi Daniel 

    In relation to your issue with creating the new subclient. 

    Under the defaultBackupSet, what are the available option?

    Is the create new subclient, greyed out?

    From the screenshot that is provided it looks like you are viewing from "Agent" perspective, if you view the Client in "CommCell Browse" when you right-click the defaultBackupSet, do you get option:

    - All Task -> New Subclient

    Thank you 

    Winston

  • Re: Backup Client installation on a mac
    Posted: 06-19-2018, 8:09 AM

    Hi Winston,

     

    i added a screenshot from the defaultbackupset.

     

    As you can see there is no option for creating a new subclient.

     

    Maybe is this a license issue? What kind of license type i need for a mac file system backup?

     

    Thanks

    Daniel


    Attachment: applefile1.jpg
The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2018 Commvault | All Rights Reserved. | Legal | Privacy Policy