Sap for Oracle backup not working

Last post 01-12-2011, 4:28 PM by SJS. 7 replies.
Sort Posts: Previous Next
  • Sap for Oracle backup not working
    Posted: 01-07-2011, 10:20 AM

    Hello,

    We have recently installed a Sap for Oracle agent on Linux and we use the BRBACKUP for it.

    I have added the symbolic link + I setup all the proper information in the init.utl file however when the backup starts the part where BRBACKUP Runs goes well but when BRARCHIVE starts it FAILS. BRARCHIVE says it doesn't see the InstanceName or ClientName however I double checked it and I cannot see what I have done wrong or what I am missing and why does BRBACKUP see the proper parameters..!?

    I have posted the last piece of logging.

    Hopefully someone out their knows what part I missed or skipped.

    -------------------------- Output of backup -------------------------

    BI_BACKUP=<ARCHIVE>
    BI_CALLER=<BRARCHIVE>
    BI_REQUEST=<NEW>


    -------------------------- Parameter Specified -------------------------


    CvInstanceName=<>
    CvClientName=<>
    numstreams=<1>
    dbname=<ECP>



    -------------------------- backint Command Line
    -------------------------

    backintCmd=[/opt/simpana/Base/../iDataAgent/backint.exe -u ZIP -f backup
    -i /oracle/ZIP/saparch/.aeewvigy.lst -t file -c ]

    Focus instance name and a focus client name has to be provided in the
    parameter file.

  • Re: Sap for Oracle backup not working
    Posted: 01-07-2011, 10:51 AM
    • efg is not online. Last active: 06-21-2019, 3:04 PM efg
    • Top 10 Contributor
    • Joined on 02-02-2010
    • CommVault Tinton Falls NJ
    • Expert
    • Points 1,658

    It sounds like you have not yet set up the SAP parameter file for the backup.   Please check the on-line documentation on setting this file.  Here is a link to the section on setting up these parameters:

    http://documentation.commvault.com/commvault/release_8_0_0/books_online_1/english_us/features/backup/sap.htm#Parameter_File

     

    This should remedy the situation.

     

    Ernie


    Ernst F. Graeler
    Senior Engineer III
    Development
  • Re: Sap for Oracle backup not working
    Posted: 01-07-2011, 11:24 AM

    Hello Ernie,

    Thank you for your reply. I have looked at the documentation several times including the link you have send. I did setup the .utl file as described in the documentation.

    The problems is that BRBACKUP does see the parameters set-up in the .utl file but BRARCHIVE does not recognize those parameters in the .utl file.

    Kind Regards,

  • Re: Sap for Oracle backup not working
    Posted: 01-07-2011, 11:59 AM
    • efg is not online. Last active: 06-21-2019, 3:04 PM efg
    • Top 10 Contributor
    • Joined on 02-02-2010
    • CommVault Tinton Falls NJ
    • Expert
    • Points 1,658

    What do you have in your init<SID>.sap configuration file?  Did you update that to point the "backup_dev_type" to util_file?  You also have to point the util_par_file parameter to the init<SID>.utl file so that brbackup looks in the right place.

     

    I have a small test db called CER and the .sap file for that contains this...

    ...

    # backup device type
    # [tape | disk | pipe | tape_auto | pipe_auto | util_file | util_vol]
    # default: tape
    backup_dev_type = util_file

    ...

    # backup utility parameter file
    # default: no parameter file
    #util_par_file = ?/dbs/init@.utl
    util_par_file = initCER.utl

    Consequently my initCER.utl file contains this:

    CvInstanceName
    Instance001
    CvClientName
    lx64cos51-3
    numstreams
    2

    My client test server is called lx64cos51-3 and I have the server set up to a 2 stream policy.

    Let me know if this helps.


    Ernst F. Graeler
    Senior Engineer III
    Development
  • Re: Sap for Oracle backup not working
    Posted: 01-10-2011, 8:52 AM

    Hello,

    Thank you for your response. I will check my files to see if I missed some settings in these files.

    I will let you know if it worked.

    Kind Regards,

    SJS

  • Re: Sap for Oracle backup not working
    Posted: 01-11-2011, 9:03 AM

    Hello EFG,

    Thanks for your help. Changing the backup_dev_type to util_file worked and we have run succesfull test backups so your help was greatly appreciated.

    I have one small question left do you know if there is a syntax to increase the trace in Backint so for future events we have more logging?

    Kind Regards,

    Damian

  • Re: Sap for Oracle backup not working
    Posted: 01-12-2011, 1:15 PM
    • efg is not online. Last active: 06-21-2019, 3:04 PM efg
    • Top 10 Contributor
    • Joined on 02-02-2010
    • CommVault Tinton Falls NJ
    • Expert
    • Points 1,658

    Hi Damian,

     

    Currently there are no debug hooks for the backint process.   I checked with the developers here and they are looking at possibly adding some hooks to our 9.0 release, but nothing is confirmed on if and when that will happen.

     

    Ernie


    Ernst F. Graeler
    Senior Engineer III
    Development
  • Re: Sap for Oracle backup not working
    Posted: 01-12-2011, 4:28 PM

    Hello Ernie,

    Thank you for your response. I will resolve this ticket now under your thread.

    Kind Regards,

    SJS

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy