Renamed AD user can't log in

Last post 03-07-2019, 2:54 AM by Mrityunjay. 3 replies.
Sort Posts: Previous Next
  • Renamed AD user can't log in
    Posted: 03-04-2019, 8:37 PM

    Hi,

    We renamed an AD user, and now he can't log in to Commvault.  More than just getting the problem solved, we're academically curious:

    • If Commvault is matching local users with AD users by username (instead of SID), and the AD group mappings are working correctly for brand-new users, why didn't Commvault create a new local user when he tried to log in?
    • To preserve account continuity, is there a way to rename the local Commvault user instead of creating a new one? (Not afraid of T-SQL or QCommands.)
    • What are other organizations doing about this issue?
    Thanks!
    Sheree
  • Re: Renamed AD user can't log in
    Posted: 03-05-2019, 12:14 AM

    Hi,

    We are sorry that you faced this issue.

    Commvault compares user GUID and updates information.

    Could you please do the following.

     

    1. increase debug level of Evmgrs to 5 (Open commvault Process Manager->go to Logging tab->you will see EvMgrS in Module column. Please set debug level to 5).

    2. Login with the said user.

    3. Once you get an error. Please copy Evmgrs.log (you can find commvault install directory in 'commvault Process Manager' General tab. Log directory would be one level above Base directory).

    4. Go to Commserver client. Right click->All Tasks->Send Log Files. In Commcell Information tab please use commserve Data base and submit it.

    5. Please let support know to forward it to us. (Reference: Mrityunjay Upadhyay, Development)

    Please let us know in case you need help with above.

     

    Thanks and regards

    Mrityunjay

  • Re: Renamed AD user can't log in
    Posted: 03-06-2019, 1:12 PM

    Hi Mrityunjay,

    He was able to log in a few hours later with no changes made.  How can we prevent this delay in the future?

  • Re: Renamed AD user can't log in
    Posted: 03-07-2019, 2:54 AM

    Hi Sheree,

     

    Good to know that the issue is resolved.

    Commvault acts immediately based on GUID received. There's no delay.

    I can't say much about prevention without seeing logs and error. 

     

    Thanks and regards

    Mrityunjay

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy