Error during DB Discovery for MS SQL AG Client

Last post 04-12-2019, 11:36 AM by jcb. 3 replies.
Sort Posts: Previous Next
  • Error during DB Discovery for MS SQL AG Client
    Posted: 04-05-2019, 6:57 AM

    Hello,

    we´ve configured ms sql ag client for our cluster. Everything is discovered successfully, but when we try to discover the dbs for subclient content, we get the error message: "protocol on server not yet implemented" (see attachment)

    Commvault CommCell, MediaAgent and Clients on Version11 with ServicePack 13

    MS SQL Cluster: Windows Server 2016 STD with MS MSQL 2017 Build: 14.0.3048.4

    I´m already downloading the latest SP to update to it. If the problem persist I´ll open a ticket at support.

    regards,

    Marius


    Attachment: Error.jpg
  • Re: Error during DB Discovery for MS SQL AG Client
    Posted: 04-08-2019, 11:28 AM

    By chance, is there a client in the environment with the same name with _1 attached to it?

     

    For example, you are trying to discover DBs on sqlclient, but you also have sqlclient_1 in the environment, possibly as a discovered VM?

  • Re: Error during DB Discovery for MS SQL AG Client
    Posted: 04-11-2019, 9:27 AM

    Yes, that was the problem. I´ve had a remote session with support and we fixed that problem as followed:

    In the Control Panel in the Commcell and User Preferences show the VM machines and you will see both in commcell browser

    Client1

    Client2

    Client1_1

    Client2_1

    had an "_1" machine and this was the VM's

    To fix this:

    openAdmin Command prompt

    drill down to the Commvault Base folder

    qlogin

    Then ran the following script

    qoperation execscript -sn QS_SetVMClient -si client name_1 -si client name

    update the SQL replicas in the SQL AG client and then they showed correctly

    Discovery is now possible.

     

  • Re: Error during DB Discovery for MS SQL AG Client
    Posted: 04-12-2019, 11:36 AM

    thanks, you saved my day Cool

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy