SAP HANA Backups are running much slower after Upgrade from V10 SP14 to V10 SP15

Last post 04-29-2019, 9:51 AM by ssunkara. 7 replies.
Sort Posts: Previous Next
  • SAP HANA Backups are running much slower after Upgrade from V10 SP14 to V10 SP15
    Posted: 03-16-2017, 10:16 AM

    Last Thursday, we did an Upgrade of out V10  from SP14 to SP15.

    Everything was still working, no immediate Problem recognized.

    After the Weekend, we have seen, that all the SAP HANA Backups are running much longer (Factor 3 to 4; i.e. 3 hours instead of 45 minutes) than before the upgrade.

    We openend a support case, got fast contact, sent Logs, did Remote-Session, collected Logs again...

    They are still working/researching for the source of the problem.

    The problem is not very disturbant for us, because the backups are still running successfully, just much slower as before. So, we just gave it a low priority :-)  Therefore, support can take time to solve this issue.

    Did anyone ran into this same problem  after an upgrade from SP14 to SP15 ?

    Have a nice day, Bumbi

  • Re: SAP HANA Backups are running much slower after Upgrade from V10 SP14 to V10 SP15
    Posted: 03-16-2017, 1:35 PM

    to be honest, the latest SP upgrades were so dramatic regarding critical issues, that it's difficult to see if there is a performance decrease.
    But for us, SP15 solved most performance related issues, but impossible to see if it's better/worse compared to for example SP12.

  • Re: SAP HANA Backups are running much slower after Upgrade from V10 SP14 to V10 SP15
    Posted: 03-17-2017, 5:51 AM

    Thanks for your reply, Bart !

    In this case, it's just the performance of SAP HANA Backups, which is giving us problems.

    All the rest is working fine or still working fine.

    The reason to upgrade from SP14 to SP15 was to test the "latest" improvements/fixes, before we have to install V11 V(6). As you might know, V11 is needed to handle ExchangeOnline and Office365.

    We have a second, smaller CV-installation, were we upgraded this week from V10 SP14 directly to V11 SP6.

    Everything over there ist still running fine - but unfortunately/fortunately, we do not have SAN HANA over there.

  • Re: SAP HANA Backups are running much slower after Upgrade from V10 SP14 to V10 SP15
    Posted: 04-28-2019, 4:36 AM

    Hi

    we have the same issue

    did you get any solution?

    Reagrd

     

  • Re: SAP HANA Backups are running much slower after Upgrade from V10 SP14 to V10 SP15
    Posted: 04-28-2019, 7:21 AM

    are you still in V10? 

    If you are in V10, there is no changes done between v10 SP14 and V10 SP15.

    Slow means, lot of factors applied. Is your File system backup for large volume going well? Can you try large file system backup also?

     

    Also Did you try parallel backup backint channels for HANA large volume?

     

    One more question is, when are you planning to upgrade to V11? Can you go to v11 SP15?

     

     

    Thanks,

    Srinivas

  • Re: SAP HANA Backups are running much slower after Upgrade from V10 SP14 to V10 SP15
    Posted: 04-29-2019, 2:14 AM

    Hi

    i have the same issue but with version  v11 SP14 (we upgare the agaent 2 weeks ago)

    so i upgrade only my dev system and i dont want to upgrade my prod system.

    we upgrade from v11 SP11 to v11 SP14 and the log hana backup that take about 20 sec

    now thak more than 2 or 3 hours and i dont know waht to do.

  • Re: SAP HANA Backups are running much slower after Upgrade from V10 SP14 to V10 SP15
    Posted: 04-29-2019, 2:38 AM

    hi,

     

    Don't forget the default behaviour for SAP Hana log backups was modified in V11 SP10. By default persistent log backups are used now. That means that a log backup will remain open for X amount of hours, before a new backup job will be started. (but within that job, sap hana will continuosly trigger log backups)
    That can explain your 2-3 hours remark.

    See: http://documentation.commvault.com/commvault/v11/article?p=22358.htm

    The persisent hana log backups are a good thing for your commvault database, but if you want, you can disable that by setting the nPersistentLogBackup parameter to 0 (see link above)

  • Re: SAP HANA Backups are running much slower after Upgrade from V10 SP14 to V10 SP15
    Posted: 04-29-2019, 9:51 AM

    Hi maxbd,

     

    You will see the log backups with backup job running for 6 hours. This is with persistent log backup we enhanced.

    If any  particular log job taking more than 30 seconds (as you said 2 hours), might not be the case. Let's say for example,  a commandline Job ID staying longer, this Job ID will take all incoming requests from the HANA for the particular colume and backup as many as can during the span of 6 hours.

    This will give you utilization of Commvault resopurces much effectively (Establiching Pipe line/request streams from Job manager side).

    Other than this any slowness you may see updating catalog, you may need to work with DBA's that might be due to the catalog not cleared with long un-necessary entries.

    Let me know if this explanation helped you. If you still had any issues, please open a TR and customer support will help you to resolve the issues.

     

    Thanks,

    Srinivas

     

     

     

     

     

     

     

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy