Report does not exist or you do not have permissions to view it

Last post 10-25-2019, 3:35 PM by Ken_H. 12 replies.
Sort Posts: Previous Next
  • Report does not exist or you do not have permissions to view it
    Posted: 09-25-2019, 9:57 AM

    After upgrading to SP16, I've started receiving email alerts from my CommVault installation.  The emails contain a "Please click here for more details" link and when I follow it, it opens a browser page to the webconsole on my CommServer that is blank except for the message:

    Report does not exist or you do not have permissions to view it.

    Does anyone know if there's documentation about how to figure ouit which report I'm missing?  Alternatively, is there anything that explains reports on the webconsole?  I've always downloaded and used the CommCell Console GUI so I imagine my webconsole hasn't been fully configured.

    Any help appreciated.

    Ken

  • Re: Report does not exist or you do not have permissions to view it
    Posted: 09-27-2019, 3:01 PM

    Hello Ken,

    What's the subject line of the email. i will try to figure out the report which its trying to open.

    Default webconsole installation includes multiple reports,  which will work out of the box.

    Please refer to the below link for more details about the reports on webconsole.

    http://documentation.commvault.com/commvault/v11/article?p=40436.htm

     

    Thanks

    Venka

  • Re: Report does not exist or you do not have permissions to view it
    Posted: 09-27-2019, 3:28 PM

    The subject line is:

    Alert: Commserv Anomaly Alert Type: Operation - Admin Alert 

    I've received several of these and the body is different.  For example:

     

    The system detected events that are unusual in occurrence or frequency.

     
     

     

    Server

    Event time

    Event

    Occurrence

    Anomaly type

    inf-srv57

    2019-09-20 22:37:16

    Synthetic Full job [324053] completed. Client [INF-SRV0], Agent Type [Windows File System], Subclient [default], Duration [00:03:32], Total Size [62.05 GB], Media or Mount Path Used [[inf-srvp110.apacorp.net] /ws/glus].

    1

    Frequency

    inf-srv57

    2019-09-20 22:33:41

    New synthetic full request received for the client [INF-SRV0], application type [Windows File System], Backup Set [defaultBackupSet], Subclient [default].

    1

    Frequency

     

     
     

    Please click here for more details.

     

    In this example the "here" link takes me to:

    http://<commserver_host>/webconsole/reportsplus/reportViewer.jsp?reportId=23&pageName=Events

     

  • Re: Report does not exist or you do not have permissions to view it
    Posted: 09-27-2019, 3:34 PM

    I don't see anything in the link you provided for either reportId=23 or pageName=Events.

  • Re: Report does not exist or you do not have permissions to view it
    Posted: 09-30-2019, 12:10 PM

    Last Friday two virtual servers were decomissioned.  CommVault dutifully sent out anomaly emails about the backups not running every hour for the entire weekend.  I don't see this report under the Reports tab in the CommVault Console and the once per hour schedule does not appear in the Report > View Schedules list. 

    I appreciate that CommVault is trying to help protect customers but it would be nice to have A) notification that this new funtionality is being deployed and B) Instructions on how to configure this.

    Ken

  • Re: Report does not exist or you do not have permissions to view it
    Posted: 09-30-2019, 2:51 PM

    I also just updated to SP16 and started seeing these alerts.

    Found from the Home Tab, Alerts, Configure Alerts area on the main commserve console.

    Agree, would be nice to have documentation on these new alerts.  Was it mentioned in the release notes?

  • Re: Report does not exist or you do not have permissions to view it
    Posted: 09-30-2019, 3:53 PM

    Thank you, thank you, thank you deb,

    Yes, the anomaly report is there and I've changed the schedule to run once every 3 hours.  I'm not sure if these emails are in the release notes as I did the SP16 upgrade as part of the work to fix a CommVault outage that stopped all my backups for five days.  As you might expect, I was getting pretty frantic by that time and threw SP16 in without really any review at all.

    Ken

  • Re: Report does not exist or you do not have permissions to view it
    Posted: 10-01-2019, 4:05 AM

    Hi,

     

    Apologies for the inconvenience caused.

     

    Anomaly feature is integrated into command centre dashboard, jobs and events pages, commcell console and alerts. You will find admin alert under operation category. There's a default created alert.

     

     Yes, I agree we missed to highlight all anomaly features and only added Deduplication Pruning Performance Alert that detects anomalies in DDB data pruning and added a link pointing to other anomaly alerts.

     

    New letter (under Data Management) : https://documentation.commvault.com/commvault/v11_sp16/article?p=108312.htm

    Predefine default alerts https://documentation.commvault.com/commvault/v11_sp16/article?p=5199.htm

    I will ensure future enhancements related to these features are added in the change section. My sincere apologies again for the inconvenience.

     

    Regarding your issues about the blank report. could you please reach out to support and share your DB to check this issue further. Please tell support to directly escalate it to Mrityunjay Upadhyay in engineering.

    I will ensure to get back at earliest.

     

    thanks and regards

    Mrityunjay

  • Re: Report does not exist or you do not have permissions to view it
    Posted: 10-01-2019, 11:03 AM

    Thanks for the information, I have enabled several additional alerts within my installation.

    Low priority incident for the "report does not exist" issue is 190923-646 which was opened on Sept 23.

    Ken

  • Re: Report does not exist or you do not have permissions to view it
    Posted: 10-01-2019, 11:59 AM

    Thank you Ken. i will take ownership of this TR and get back by end of the week.

     

    thanks and regards

    Mrityunjay

  • Re: Report does not exist or you do not have permissions to view it
    Posted: 10-24-2019, 10:12 AM

    Update on this for posterity...

    It turns out the Anomaly Report is hidden and the solution was to un-hide the report by making it visible to everyone.  The situation is that CommVault choose to automatically start sending out anomaly emails containing a link to a hidden report.  It's easy to see how this could happen - probably different teams for email notifications versus report generation.  What's frustrating is that it took CommVault support almost a full month to track down the problem. 

    Dear CommVault,

       Please do better.

    Signed, Your Clients.

  • Re: Report does not exist or you do not have permissions to view it
    Posted: 10-24-2019, 11:22 AM

    Hi Ken,

    Thank you for your feedback. 

     

    The default alert is sent to commcell admins and this has a link to an admin report. The report is marked hidden as it's not for common business function usage, can contain information related to entire commcell (eg: drop in success rate) and the report is tied to alert instance using time-range inputs.

     

    In your case; user wasn’t an admin; hence support tried to give you access by manually giving you right on the report.

     

    Please feel free to write to me directly at mupadhyay@commvault.com with your criticism and improvements requirements. 

     

    Apologies for the inconvenience. 

     

    Thanks and regards

    Mrityunjay

    Development

  • Re: Report does not exist or you do not have permissions to view it
    Posted: 10-25-2019, 3:35 PM

    Just some further clarification...

    Our internal security is set up so that I have multiple network accounts (each with a different password):

    •  KH****   is the account I use on my local desktop
    • A-KH**** is an administrator account I use to connect to servers
    • D-KH**** is a domain administrator account for times I need to change AD

    Of the three accounts, only the normal KH**** can send and receive email.  A-KH**** is used to connect to and administrer the CommVault servers.

    Thank you for the previous update on this post.  The access to this report is fairly intuitive but, as noted above, it can have problems with newer security models that use multiple accounts to enforce separation of access / duties / responsibility.

    Ken

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy