Message Level Recovery using old Exchange Database Agent - Create Recovery Point fails

Last post 09-26-2019, 3:37 AM by DISC. 2 replies.
Sort Posts: Previous Next
  • Message Level Recovery using old Exchange Database Agent - Create Recovery Point fails
    Posted: 04-09-2019, 6:33 AM

    Hi,

     

    We've had a DAG configured with the old Exchange Database agent since SP10. We recently decided we wanted to do message level recovery. This requires the following steps to be taken on a Media Agent:

     

    - Install a Database Agent

    - Outlook 2010 or later installed

    - Visual C++ Redistributable for Visual Studio 2012 Update 4

    - .NET 4.5 or later

     

    The only one of these conditions that was not met was the database agent, which I couldn't install from a v15 CommServe with an up to date software cache. Instead, I installed the new Exchange agent on the Media Agent instead.

     

    The problem is that now, when I try to create a recovery point, the job fails almost instantly and the only indication of why in the logs is listed below:

    11276 23e8  04/09 10:19:07 18075 ReplayExchangeLogs() - Replay logs without hard repair
    11276 23e8 04/09 10:19:11 18075 CJetLogReplay::PerformRecovery() - PerformSoftRecovery with eseutil
    11276 23e8 04/09 10:19:11 18075 ::runProgram() - Exit Code = -1073741515/-1073741515
    11276 23e8 04/09 10:19:11 18075 ::PerformSoftRecoveryEseutil() - Error soft recovery due to bad files.
    11276 23e8 04/09 10:19:11 18075 CJetLogReplay::PerformRecovery() - PerformSoftRecovery with eseutil failed
    11276 23e8 04/09 10:19:11 18075 ReplayExchangeLogs() - Failed to replay logs from edb [this defines the edb path which I removed]

     

    Has anyone else experienced this?

    Thanks in advance.

  • Re: Message Level Recovery using old Exchange Database Agent - Create Recovery Point fails
    Posted: 04-11-2019, 9:54 AM

    It turns out we actually had the wrong version of C++ installed.

     

  • Re: Message Level Recovery using old Exchange Database Agent - Create Recovery Point fails
    Posted: 09-26-2019, 3:37 AM

    we have same issue, can u please provide us detasils about version of c++ needed?

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy