Report confusion

Last post 10-01-2019, 5:33 PM by Ken_H. 9 replies.
Sort Posts: Previous Next
  • Report confusion
    Posted: 09-30-2019, 5:09 PM

    Dear CommVault:  The report you provide with your product are very confusing.  If possible, I believe it would be helpful for customers if there was consistency between the various ways that reports are accessed.

    For example:  When I remote into my CommServer host and browse to http://localhost/webconsole, I can find a very informative graph showing growth in my disk library:

     

    However, If I use a browser on my desktop and connect to my CommServer, I don't see the above report as an option:

     

    Finally, if I go to cloud.commvault.com, there is a growth report but it is missing the graph showing historical growth:

     

    I would sincerely appreciate if the reporting could be standardized so that clients don't have to go to three different locations and search amoung several reports in the hopes of finding one that they can use.

    Thanks

     

     

     

  • Re: Report confusion
    Posted: 09-30-2019, 8:28 PM

    I looked into this about six months ago and I concur.

    It does seem that in order to get statistics on library growth that you have to rely on metrics collection intervals.  This is because Commvault concluded that the CommServ DB table MMLibraryHistory did not populate correctly if the data is deduped and it also came with a performance hit in larger Commvault environments.  There is a CMR logged to possibly address this in a future service pack.

  • Re: Report confusion
    Posted: 10-01-2019, 11:06 AM

    Hello Ken,

    did you login with the same account to when using http://localhost/webconsole and when you accessed the URL from a remote machine. ?

    or dont use localhost and use the Hostname (login as admin)and see if you find the report. 

     We have around 200 Reports on Commvault Store that can be installed on Private Reporting server as required. All these reports are customizable by the end user.

    https://store.commvault.com/Reports

    Cloud will not have these reports and will have only the Canned Metrics Reports and that's the reason why you dont see this report on cloud. from the screenshots i see that you dont have Metrics reporting sever installed in your environment. Metrics Reporting server will give you historical trending and Chargeback reports.

    http://documentation.commvault.com/commvault/v11/article?p=37690.htm

    Thanks

    Venkat

     

     

     

  • Re: Report confusion
    Posted: 10-01-2019, 11:58 AM

    Hello Venkat,

    Yes, you are correct, I am using different accounts.  On my desktop I am authenticated as KHemmerling but when connected to the CommServer I have to use my administrator account:  A-KHemmerling.  If I run a browser as A-KHemmerling on my desktop, I see the same reports.  If possible, can you provide a link that shows where this security is configured?  Ideally I'd like to have my two accounts see the same thing.

    On the CommServer, switching between http://localhost/webconsole and http://<commserver_name>/webconsole provided the exact same list of reports.

    I'll review the links you provided.  Thanks for your help.

    Ken

  • Re: Report confusion
    Posted: 10-01-2019, 12:11 PM

    Hello Ken,

    Thank you for the confirmation. you have the option to share a report with other users. login as admin >  open the report > Click on File (right top)> Security > search and select the user > drop down the presmissions menu and select execute > click on the + and click on the update Button.

    i have attached the screenshot for your referrence.

    thanks


    Venkat


    Attachment: Reportsecurity.JPG
  • Re: Report confusion
    Posted: 10-01-2019, 1:39 PM

    Hello Venkat,

    I can now see the Library Growth report when using the browser on my desktop under my normal account.  Unfortunately, when I run the report, it comes up blank.  Any suggestions on where the problem is?

    Ken

  • Re: Report confusion
    Posted: 10-01-2019, 3:01 PM
    Hello Ken,
    is the report blank or does it say "no data available" ?
    if its blank, try once in browser's incognito mode.
    if it says "no data available", check the below : 
    Do you see the libraries if you login into the Java console with the same account. ? i just want to make sure that this account has at least view capability on the libraries.
    Most of the reports have inbuilt security in them, they show the entities that the user is associated with. 
    thanks
    Venkat
  • Re: Report confusion
    Posted: 10-01-2019, 3:10 PM

    I get "No data available". 

    Using my regular account I can run the Console, see the libraries, and right-click > Properties > Disk Usage (tab) and see the free space.

    Ken

  • Re: Report confusion
    Posted: 10-01-2019, 4:54 PM

    Hello Ken,

    Can you confirm the account you are using 

    KheXXXXXX or A-KheXXXX

    KhemXXXXX is an account which is for search & Compliance and doesnt have any other capabilities and the report will not show any data.

    if you want to use this account, you can give this account Report management Capability at the CommCell level. 

    A-KhemXXXX has admin capabilites and should show data in the report.

     

     

    Thanks

    Venkat


    Attachment: Reportmanage.JPG
  • Re: Report confusion
    Posted: 10-01-2019, 5:33 PM

    Hello Venkat,

    The report appeared incomplete in the browser on my desktop but after a bit of patience and a few refreshes it looks perfect.  Thanks for your help.

    Ken

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2019 Commvault | All Rights Reserved. | Legal | Privacy Policy