Cross database version restore fails.

Last post 03-05-2020, 9:23 AM by Sunil Telagamsetti. 3 replies.
Sort Posts: Previous Next
  • Cross database version restore fails.
    Posted: 01-24-2020, 10:45 AM

    Hi All,

    We are trying to restore a SAP S/4 HANA backup (QHA/Q1A) to the same server in a different database (QGA/Q1A).

    A backup of October 31.10.2019 was made on source database level 2.0.024. After that, we upgraded source database (QHA) from 2.0.024 to 2.0.044 on 05.11.2019. After this upgrade there were regular backups of the upgraded source database. We tried restoring the backup of October 31.10.2019 into target database level 2.0.024 which doesn’t succeed.

    We tried 2 different databases on different hosts with level 2.0.024 both unsuccessful.
    We tried restoring the backup of October 31.10.2019 into target database level 2.0.044 which was successful. However this level is undesired as the application is not compatible with level 2.0.044.

    The source database was upgraded 05.11.2019. After that the database was on level .044 and regular backups continued. We try restoring a full database backup dated 31.10.2019 into a target DB .024 which fails.

    We also tried an older backup to restore but same result.

    At this moment when we try to restore, the restorejob comes with below error:

    Error Code: [18:146]
    Description: SAP HANA Error [Failed to write the file=/usr/sap/QGA/SYS/global/hdb/backint/DB_Q1A/log_backup_0_0_0_0].
    Source: vmsapt001, Process: backint_hana

    vmsapt001:/usr/sap/QGA/SYS/global/hdb/backint/DB_Q1A # ls -latr

    total 4
    drwxrwxrwx 8 qgaadm sapsys 4096 Jan 22 00:42 ..
    drwxrwxrwx 3 qgaadm sapsys   24 Jan 24 16:29 .
    vmsapt001:/usr/sap/QGA/SYS/global/hdb/backint/DB_Q1A #

    Please let me know if additional information is needed.

    Thanks in advance!


  • Re: Cross database version restore fails.
    Posted: 01-31-2020, 9:33 AM

    Hi Marcel,

    Which Commvault version and service pack are you using?

     

    While submitting the restore, can you also select the Catalog point-in-time from Advanced options and retry your restore?

     

    The failure to restore to 2.0.024 version may be because of the catalog version incompatibility. HANA restores latest catalog always which would have been 2.0.044. This can be overridden using catalog point-in-time option.

     

    Thanks,

    Sunil-

  • Re: Cross database version restore fails.
    Posted: 01-31-2020, 9:42 AM

    Hi Sunil,

     

    We are using 11SP15 HKP29 (build 80).

    We also got this answer from SAP, trying this as we speak.. Let you know the results.

     

    KR,

    Marcel

  • Re: Cross database version restore fails.
    Posted: 03-05-2020, 9:23 AM

    Hi Marcel,

    May I bother you to know about your test result? Did restoring the catalog from that specific point-in-time help?

     

    Thanks,

    Sunil-

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2020 Commvault | All Rights Reserved. | Legal | Privacy Policy