iFind Vss issue with system state

Last post 01-31-2020, 12:26 PM by deb. 5 replies.
Sort Posts: Previous Next
  • iFind Vss issue with system state
    Posted: 01-29-2020, 12:52 PM

    When backing up 1 Windows MA, the file sync is failing trying to create VSS snapshots.  Windows event logs report VSS failure with "system reserved" volume.  If I turn off backing up the system state for that MA, the backup of the MA filesystem run fine.  I've restarted the services, and then the server.  Did not make a difference. 

    This all started coincidently after removing a disk (actually a jbod) from the MA on Monday, and rebooting the server at that time. 

    Running vssadmin list writers, shows the System Writer and WMI Writer in a failed state. 

    Again, I can restart the services and/or reboot the machien, and the writers all show as "ok". 

    They only go into the failed state when I try doing a backup of the MA, which includes saving the system state.

    Running V11 SP16

    Any hints?

  • Re: iFind Vss issue with system state
    Posted: 01-29-2020, 4:01 PM

    Windows event log:

    Event ID 12289

    Unexpected error DeviceIoControl.... The parameter is incorrect

    Sample of messages in filescan.log

    10400 1f28  01/29 01:52:09 477182 CsSnapRequestor::DoShadowSet() - Call asyncShadow.WaitUntilDone()  [FAILED, throwing CV exception] - Code = 0x80042306, Description = VSS_E_PROVIDER_VETO
    10400 1f28  01/29 01:52:09 477182 CsSnapRequestor::CreateSnapshotSet() - Call DoShadowSet()  [FAILED, throwing CV exception] - Code = 0x80042306, Description = VSS_E_PROVIDER_VETO
    10400 1f28  01/29 01:52:09 477182 CsSnapRequestor::Snap() - Call CreateSnapshotSet()  [FAILED, throwing CV exception] - Code = 0x80042306, Description = VSS_E_PROVIDER_VETO
    10400 1f28  01/29 01:52:09 477182 CsSnapRequestor::DeleteSnapshot() - Shadow not created!
    10400 1f28  01/29 01:52:09 477182 CsSnapRequestor::BackupComplete() - Deleted snapshot set
    10400 1f28  01/29 01:52:09 477182 CsSnapRequestor::BackupComplete() - Aborting backup!

  • Re: iFind Vss issue with system state
    Posted: 01-30-2020, 11:46 AM
    • Aplynx is not online. Last active: 04-01-2020, 9:30 AM Liam
    • Top 10 Contributor
    • Joined on 05-04-2010
    • New Jersey
    • Master
    • Points 1,818

    Are you able to run a successful system state backup using the native windows backup application?

  • Re: iFind Vss issue with system state
    Posted: 01-30-2020, 7:30 PM

    It is possible that the missing JBOD disk had a piece of VSS data, that broke the VSS chain. In that case, delete all VSS data and re-create VSS and start again. Yes that will delete all old snapshots but if it is corrupted, it is not good any more.

    The event ID 12289 should have an error code like 0x800xxxxxxx, which can give you more clue.

  • Re: iFind Vss issue with system state
    Posted: 01-31-2020, 12:08 PM

    Not sure how to do that.

    One thing I notice in looking at the other MAs in our environmemt.  If I look at the windows "Configure shadow copies" screen, it is only this one particular MA that shows the "reserved system" volume.  And if I look at the settings for that, it shows "total disk space 350MB, Free space 72MB".  I'm wondering why this is the only MA with this volume and if the reason it is breaking, is that there is no room to create a snapshot, and whether it even needs one.

    I did clear out the old snapshots (were for the C: drive), and tried a backup with the "system state backup" re-enabled, but that failed

  • Re: iFind Vss issue with system state
    Posted: 01-31-2020, 12:26 PM

    I went into Windows, and changed (at least I think I did Smile), where the snapshot is created for the "system reserved" partition, re-ran the backup and it apparrently succeeded. Looks like it did not have enough space to create the snapshot in the original location.  Will hold off on declaring victory for a while. 

    As mentioned, I looked at my other MAs, and they do not show the "system reserved" volume under Shadow Copies.

    Strange.

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2020 Commvault | All Rights Reserved. | Legal | Privacy Policy