User Mailbox Restore

Last post 05-13-2020, 9:19 PM by ddwyer. 3 replies.
Sort Posts: Previous Next
  • User Mailbox Restore
    Posted: 03-21-2020, 5:14 PM
    Hello,

    I get the following error during user mailbox restore.
    I did not get any results from the research I have done on the subject.
    Anyone experiencing this problem?

     

    Error Code: [14:139]
    Description: Browse failed during searching for results in the index.
    Source: xxx-MA1, Process: CVMailRestoreCoordinator     

     

    CVMailRestoreCoordinator.log ;
    30148 2644  03/22 00:03:44 95647 ExAgentCoordinator::OnIdle_Starting() - All Agents have initialized, Number of Agents ready [1], Agents failed to start [0]
    30148 2644 03/22 00:03:54 95647 ExAgentCoordinator::AssignDataToAgents() - Assigning data [\MB\{E5D5B953XB815X4E71X989FX66C80E73C134 : xxx} : 1] to agent [xxx-MA1_Remote0]
    30148 2644 03/22 00:03:57 95647 ExAgentCoordinator::OnMsgDataOperationover() - Received Status [RETURN_NO_PROCESSING_DONE_SUSPENDED] for data [1] from [xxx-MA1_Remote0]
    30148 2644 03/22 00:03:57 95647 ExAgentCoordinator::OnMsgDataOperationover() - Data [1] returned by agent [xxx-MA1_Remote0] without processing, set it as not processed, and mark it blocked for the agent
    30148 2644 03/22 00:03:57 95647 ExAgentCoordinator::MarkDataFailedIfItsBlockedByAllAgents() - Data [\MB\{E5D5B953XB815X4E71X989FX66C80E73C134 : xxx} : 1] marked as FAILED as its blocked by all running agents
    30148 2644 03/22 00:03:57 95647 ExAgentCoordinator::OnIdle_Running() - All the controllers are in suspended state shutting down all agents in 5 min
    30148 2644 03/22 00:03:57 95647 Message [ExchangeVirtualAgent_EVCAgentShutdown] received from Agent [xxx-MA1_Remote0]
    30148 2644 03/22 00:03:57 95647 ExAgentCoordinator::OnAgentStopped() - Agent [xxx-MA1_Remote0] has stopped due to error [234881163 : Browse failed with error: Search preparation failed. : 1], running for 0.216667 min
    30148 2644 03/22 00:03:57 95647 ExAgentCoordinator::OnIdle_Running() - All the data items are processed, stop all agents
    30148 2644 03/22 00:03:57 95647 CVRemoteAgentServer::MonitorAgents() - There are no running agents
    30148 2644 03/22 00:03:57 95647 Final Restore Job Statistics
    30148 2644 03/22 00:03:57 95647 Shared job specific dir [\\xxx\C$\Mailbox_JobResults\JobResults\CV_JobResults\2\2\95647]
    30148 2644 03/22 00:03:57 95647 Final Restore Job Stats : Mailboxes Successful : [0], Mailboxes Failed : [0], Mailboxes Suspended : [0], Mailboxes Skipped : [0], Successful Items : [0], Failed Items : [0], Ineligible Items : [0], Bytes Read : [0]
    30148 57dc 03/22 00:03:57 95647 setXmlBlob() call received xml [<?xml version="1.0" encoding="UTF-8" standalone="no" ?><JobManager_RstJobDetailsXml><exchOnePass><restoreJob mailboxesFailed="0" mailboxesSkipped="0" mailboxesSuccessful="0"/></exchOnePass></JobManager_RstJobDetailsXml>] for job 95647
    30148 2644 03/22 00:03:57 95647 Sending FAILED complete message to JM, 95647
    30148 112c 03/22 00:03:57 95647 CVJobCtrlLog::unregisterProcess(): successfully removed file [C:\Program Files\Commvault\ContentStore\Base\JobControl\30.148]
     
    thank you
  • Re: User Mailbox Restore
    Posted: 05-13-2020, 8:10 PM

    Hi,

    Apologies for the delayed response, this issue usually means that the browse from web server against the Index Server is failing.

    If you check the DM2Web.log on your webserver can you see any issues with the server attatching to the Index on the IndexServer?

    Also would suggest checking the CVMailRestore.log on the access node to see whether there are any errors with more information. 

    David

  • Re: User Mailbox Restore
    Posted: 05-13-2020, 8:32 PM
    Hi,
    Thanks for your answer. When I reviewed the DM2Web.log, I found errors like the one below. Are these descriptive for you?
    22452 425   05/08 15:20:34 ### ### csBase::doSelectCommand - Exception [System.Data.SqlClient.SqlException]. Error message ...
    A transport-level error has occurred when receiving results from the server. (provider: TCP Provider, error: 0 - The semaphore timeout period has expired.)
    22452 425 05/08 15:20:34 ### ### csBase::doSelectCommand - Exception Message [A transport-level error has occurred when receiving results from the server. (provider: TCP Provider, error: 0 - The semaphore timeout period has expired.)]
    22452 425 05/08 15:20:34 ### ### csBase::doSelectCommand - Exception Source [.Net SqlClient Data Provider]
    22452 425 05/08 15:20:34 ### ### csBase::doSelectCommand - Exception InnerException [System.ComponentModel.Win32Exception (0x80004005): The semaphore timeout period has expired]
    22452 425 05/08 15:20:34 ### ### csBase::doSelectCommand - Exception StackTrace [ at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)
    at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)
    at System.Data.SqlClient.TdsParserStateObject.ReadSniError(TdsParserStateObject stateObj, UInt32 error)
     
    11360 184   05/12 06:29:21 ### ### csBase::doSelectCommand - Exception [System.Data.SqlClient.SqlException]. Error message ...
    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - The wait operation timed out.)
    11360 184 05/12 06:29:21 ### ### csBase::doSelectCommand - Exception Message [A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - The wait operation timed out.)]
    11360 184 05/12 06:29:21 ### ### csBase::doSelectCommand - Exception Source [.Net SqlClient Data Provider]
    11360 184 05/12 06:29:21 ### ### csBase::doSelectCommand - Exception InnerException [System.ComponentModel.Win32Exception (0x80004005): The wait operation timed out]
    11360 184 05/12 06:29:21 ### ### csBase::doSelectCommand - Exception StackTrace [ at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, SqlCredential credential, Object providerInfo, String newPassword, SecureString newSecurePassword, Boolean redirectedUserInstance, SqlConnectionString userConnectionOptions, SessionData reconnectSessionData, DbConnectionPool pool, String accessToken, Boolean applyTransientFaultHandling, SqlAuthenticationProviderManager sqlAuthProviderManager)
     
    15952 169   05/14 03:27:25 196034 xxx\xxx SearchImpl::ensureGalaxySecurity() - Exception Message [The server is not operational.
    ]
    15952 169 05/14 03:27:25 196034 xxx\xxx SearchImpl::ensureGalaxySecurity() - Exception Source [System.DirectoryServices]
    15952 169 05/14 03:27:25 196034 xxx\xxx SearchImpl::ensureGalaxySecurity() - Exception StackTrace [ at DM2WebLib.Security.ADAuthenticator.BindForAd(String userAlias, String pwd, String domain, Boolean bUseSSL, String proxyHost, Boolean isJumpCloud)
  • Re: User Mailbox Restore
    Posted: 05-13-2020, 9:19 PM

    Hi Hanzala,

    Can you confirm whether the Commserve and Web Server are separate machines here? Is there a firewall between them? 

    It looks like there is an issue with the webserver connecting to a SQL instance here. I believe it would be the COMMVAULT instance running on the Commserve.

    If the Commserve and Webserver are separate servers, can you ensure that the webserver is able to commmunicate with the Commserve on UDP 1434 to hit the SQL browser service and the TCP port that SQL srever is listening on to allow communication with the instance? 

    To find out which port we are listening on, open SQL Server Configuration Manager on the Commserve, expand the SQL Server Network Configuration options, then click on Protocols.

    Right-click on TCP/IP and select Properties. Select IP Addresses tab and scroll down to the IPAll listing. This will have the current TCP Dynamic Port we are listening on.

    Open this port in any firewall you have between Webserver and Commserve and then retry the restore.

    David

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2020 Commvault | All Rights Reserved. | Legal | Privacy Policy