MySqlBrowseAgent problem

Last post 10-20-2020, 4:37 AM by Sunil Telagamsetti. 10 replies.
Sort Posts: Previous Next
  • MySqlBrowseAgent problem
    Posted: 06-11-2020, 8:31 AM

    When do try to install CV backup on new Linux machine (Debian 10) File system went OK, but the problem is with Mysql connection. System recognize instance, but when I fill with all information I got error like on attached pic.

    What can be a problem?

    I must add, that other Linux machines Mysql backup working, only on this new one I cant add MySql content.

    Thanks

  • Re: MySqlBrowseAgent problem
    Posted: 06-11-2020, 8:44 AM

    Hi,

    Can you see MySQLBrowseAgent.log file on the client to see if there are any obvious errors?

    You verified the credentials and other information, right?

     

    Thanks,

    Sunil-

  • Re: MySqlBrowseAgent problem
    Posted: 06-11-2020, 8:52 AM

    There is a two files:

    /var/log/commvault/Log_Files/locks/MySqlBrowseAgent.log
    /var/log/commvault/Log_Files/MySqlBrowseAgent.log

    when I check second one I only this row that can be a problem:

    9883 269b 06/11 10:05:08 ### GetMySqlInfoExt::Init() - MySqlInterface::LoadAndInitialize() failed:Can't connect to local MySQL server through socket '/var/lib/mysql/m
    ysql.sock' (2) Failed to execute mysql_real_connect
    9883 269b 06/11 10:05:08 ### MySqlBrowseAgent::DoBrowse() - Cannot Initialize GetMySqlInfo Object

     

    or this:

    9588 2574 06/11 11:32:14 ### Cvcl::init() - CVCL: Running in FIPS Mode
    9588 2574 06/11 11:32:14 ### MySqlBrowseAgent::DoBrowse() - Connected backto the requestor
    9588 2574 06/11 11:32:14 ### MySqlBrowseAgent::InitMysqlServer() - InitMysqlServer 2
    9588 2574 06/11 11:32:14 ### isCCSDbEnabled() - Use CCSDb Enabled [0] IsCloudLaptop [0] IsFSCoreLaptop [0]
    9588 2574 06/11 11:32:15 ### MySqlBrowseAgent::AppMgrInit() - Got all the information from appmanager...
    9588 2574 06/11 11:32:15 ### MySqlBrowseAgent::AppMgrInit() - autoDiscoverFlag = 1
    9588 2574 06/11 11:32:15 ### MySqlBrowseAgent::AppMgrInit() -  Unix User :
    9588 2574 06/11 11:32:15 ### MySqlBrowseAgent::AppMgrInit() - SocketFile = /run/mysqld/mysqld.sock
    9588 2574 06/11 11:32:15 ### MySqlBrowseAgent::AppMgrInit() - SSL-CA File =
    9588 2574 06/11 11:32:15 ### MySqlBrowseAgent::AppMgrInit() - libPath = /opt/commvault/Base
    9588 2574 06/11 11:32:15 ### MySqlBrowseAgent::DoBrowse() - MySql Server : , sa user: backup sock/port: /run/mysqld/mysqld.sock
    9588 2574 06/11 11:32:15 ### MySqlBrowseAgent::DoBrowse() - Starting here
    9588 2574 06/11 11:32:15 ### GetMySqlInfoExt::sslConnect() - SSL not configured for the server.
    9588 2574 06/11 11:32:15 ### CvBacktracer() - PID 9588, signal 11 (Segmentation fault), address 0x459

  • Re: MySqlBrowseAgent problem
    Posted: 06-11-2020, 2:22 PM

    Hi,

    Can you please log in to mysql with backup user and get output of show grants.

    Aslo Please get me the version of MySQL server.

    Thanks

    Sudheer Chigullapally

  • Re: MySqlBrowseAgent problem
    Posted: 06-11-2020, 2:40 PM
    :~# mysql -u backup -p
    Enter password:
    Welcome to the MariaDB monitor. Commands end with ; or \g.
    Your MariaDB connection id is 73
    Server version: 10.3.22-MariaDB-0+deb10u1 Debian 10
     
    MariaDB [(none)]> show grants;
    +----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
    | Grants for backup@localhost |
    +----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
    | GRANT SELECT, RELOAD, SHOW DATABASES, SUPER, LOCK TABLES, REPLICATION CLIENT ON *.* TO 'backup'@'localhost' IDENTIFIED BY PASSWORD '*6BBDF8100DD23C8740083C5A9C535E43007B60BF' |
    | GRANT SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, REFERENCES, INDEX, ALTER, CREATE TEMPORARY TABLES, LOCK TABLES, EXECUTE, CREATE VIEW, SHOW VIEW, CREATE ROUTINE, ALTER ROUTINE, EVENT, TRIGGER ON `procena\_uticaja`.* TO 'backup'@'localhost' |
    +----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
    2 rows in set (0.000 sec)
  • Re: MySqlBrowseAgent problem
    Posted: 06-12-2020, 2:15 AM

    Hi, 

    Configuration on your setup is fine, debian 10 is not yet certied by commvault for MySQL.

    Please create a ticket to add supoort for debain 10 for MySQL.

    https://documentation.commvault.com/commvault/v11/article?p=3022.htm

    Thanks

    Sudheer Chigullapally

     

  • Re: MySqlBrowseAgent problem
    Posted: 06-12-2020, 3:02 AM

    Hello Sudheer,

    I trought that about new Debian edition. So you sugest to open ticket or to wait maybe in some next HotFix CV will add Debain 10 into. So the problem is only in MySql, File system is working very well.

    Regards,

  • Re: MySqlBrowseAgent problem
    Posted: 06-12-2020, 3:03 AM

    Hello Sudheer,

    I trought that about new Debian edition. So you sugest to open ticket or to wait maybe in some next HotFix CV will add Debian 10 into. So the problem is only in MySql, File system is working very well.

    Regards,

  • Re: MySqlBrowseAgent problem
    Posted: 07-03-2020, 5:01 AM

    Is there any information when Debian 10 will be supported? Let's not open the ticket if it will be in the next updates.


    I was expecting in the latest, because Debian 10 was initially released as version 10 on July 6th, 2019 and its latest update, version 10.4, was released on May 9th, 2020.

    Thanks

  • Re: MySqlBrowseAgent problem
    Posted: 10-20-2020, 4:28 AM

    Any information when Debian 10 will be supported?

    Our MySql Agent on that machine still not works.

    Regards,

  • Re: MySqlBrowseAgent problem
    Posted: 10-20-2020, 4:37 AM

    Hi,

    Could you please escalate a ticket through support?

    We have certified MySQL on Debian in SP20. We can debug the issue further through support ticket.

     

    Thanks,

    Sunil-

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2020 Commvault | All Rights Reserved. | Legal | Privacy Policy