LTO-4 drives dropping offline

Last post 05-23-2011, 2:42 PM by Tom Watson. 6 replies.
Sort Posts: Previous Next
  • LTO-4 drives dropping offline
    Posted: 05-19-2011, 1:46 PM

    We have a Dell ML-6000 (essentially an ADIC/Quantum scalar i500) with IBM fibre LTO-4 drives.  The drives keep falling off-line.  Commvault told us to get the latest drivers.  Dell said to use the Windows drivers.  First, we tried getting the drivers from IBM.  We got the 64 bit drivers and installed them.  It caused our system to blue screen.  We did a last known good configuration to get back to functioning.  We then tried to use the "Update Driver" from the device manager.  It did update the driver, and we went from version 6.0.6001.18000 (C:\Windows\system32\DRIVERS\ltotape.sys) to version 6.1.8.0, but they showed up as "Windows cannot initialize the device driver for this hardware" after a reboot.  They look like IBM 32 bit drivers, possibly for a Windows 2003 32 bit system (C:\Windows\system32\DRIVERS\ibmtp2k3.sys).  We are on Server 2008/64 bit.  Any ideas on how to get the latest functionable drivers installed?

    Beth

  • Re: LTO-4 drives dropping offline
    Posted: 05-19-2011, 7:02 PM

    Beth,

    Did you notify IBM that the drivers provided caused the system to blue screen?  I would probably recommend going that route first.  I did a quick Google search for drivers for the Dell ML-6000 and found the following links:

    http://download.cnet.com/Tape-Automation-Dell-Powervault-ML6000-Driver-Version-A03/3010-2122_4-180091.html

    http://download.cnet.com/Tape-Automation-Dell-Powervault-ML6000-Driver-Version-A01/3000-2122_4-174270.html

    JW

     

  • Re: LTO-4 drives dropping offline
    Posted: 05-20-2011, 4:36 AM
    • mort is not online. Last active: 01-13-2016, 10:37 AM mort
    • Top 50 Contributor
    • Joined on 07-06-2010
    • Patrick
    • Adept
    • Points 209

    Hi Beth,

    What IBM Driver version are you using?

    According to CommVaults Hardware Compatibility Matrix, the latest supported drivers for IBM LTO4 Drives is 6.2.1.5, I can confirm that we are using these drivers on both W2K3 and W2K* both 32 and 64 bit with no problems.

    A quick check of the IBM site revealed that there is a 6.2.1.6 Driver, that could be worth testing, I've attached W2K3/W2K8, 32-Bit and 64-Bit versions, be aware that these are not listed on the CommVault HC Matrix.

    Also make sure you run the install_nonexclusive.exe, which installs all needed drivers and registry settings, rather than just update drivers from the device manager.

    Please keep us informed.

  • Re: LTO-4 drives dropping offline
    Posted: 05-20-2011, 1:38 PM

    There may be more to this. I have an Quantum i2K with IBM LTO3 drives. We just upgraded the library to the latest Quantum firmware and all the drives were updated as well and then we started to experience random drives just dropping off. May be a firmware issue with the library/drives.

    I spoke with CV support and they had me remove the Medium Changer driver from the ADIC i2K driver to the "Unknown Medium Changer" driver. Said the Mfg drivers have caused random flakeyness so they always recommend changing it. I didnt understand how it could make a difference but went ahead and did it. It didnt make any difference and I am still loosing random drives during operations. I am considering rolling back the i2K firmware and the drive firmware to see if that makes any difference.

  • Re: LTO-4 drives dropping offline
    Posted: 05-20-2011, 2:39 PM

    I am having a similar issue. 
    DELL ML6000 tape library, IBM Ultrium-TD4 tape drives, HP server running
    Windows 2003 32-bit, FC attached single initiator/single target, Brocade Fabric.  This ran for years and all of a sudden April
    26th it decided to stop working. 
    I have been working on the issue for two weeks now and have pretty much exhausted
    all possible cause and was ready for a rebuild until I read this forum.

    Here is what is happening to my tape drives.  They initially scan the SCSI bus and report
    back the serial number and WWNs to CommVault; I run the scanscsitool.exe to
    confirm.  Then when I run an AuxCopy the
    tape drives disappear, run scanscsitool.exe again and the serial number and
    WWNs have disappeared as well…  CommVault
    uses the serial number as the unique identifier for communicating with the tape
    drives!  So when CommVault can’t communicate
    it writes the media as BAD.

    Around the time this started happening will applied Microsoft
    patches to the server, will also applied patches to CV to Simpana 9 SP2.  The first thing I tried was to back out all
    patches to a point where the library was writing data to tape…  I did not fix the issue.  I then reapplied all patches up to date,
    still no go.

    I had updated the Emulex HBA firmware and drivers to the
    latest version, it is an HP branded card so I used HP approved drivers.  The tape drives were flashed to the latest
    DELL approved firmware and device drivers. 
    Still no go!

    I tried making the drives persistent in the OS via the
    registry.  Did not do anything…  I have worked with six DELL technicians over
    the last two weeks and we tried everything under the sun.  They said to contact HP because they were at
    a loss.  I can send more info on what we
    tried.

    I did try Emulex drivers and firmware – non-HP branded as
    well as the newest IBM Ultrium-TD4 tape drivers – non-DELL apporved.  The Emulex drivers were fine.  The IBM drivers fixed the problem with the
    Tape serial number and WWNs disappearing however it would hang the server, so I
    backed those out to version 6.1.8.0, tried again and the drives disappeared
    again.

    I am still at this point and have nothing left but to
    rebuild the server on new hardware to rule that out… 

  • Re: LTO-4 drives dropping offline
    Posted: 05-23-2011, 10:06 AM

    I just spoke with my Quantum/ADIC SE and now am really confused. According to him the difference between the exclusive and non-exclusive is:

    install_exclusive.exe:

     install_exclusive.exe should be used by applications (such as Tivoli Storage Manager)
     requiring the driver to issue automatic reserves on open and also preventing multiple
     open handles from a host to a drive to exist at the same time.

            Note: This option replaces the previous default installation of install.exe


    install_nonexclusive.exe:

     install_nonexclusive.exe should be used by applications (such as Microsoft Data
            Protection Manager or Microsoft Removable Storage Manager) permitting multiple open
     handles from a host to a drive to exist at the same time.

     

    So my question is which driver does Commvault require?

  • Re: LTO-4 drives dropping offline
    Posted: 05-23-2011, 2:42 PM

    Got a response back from Commvault support on the drivers. He said that we should be using the "Non-Exclusive" driver install. I reinstalled the driver and the drives have not dropped offline since. Looks like that fixed the issue. I didnt even have to upgrade to the latest driver version.

The content of the forums, threads and posts reflects the thoughts and opinions of each author, and does not represent the thoughts, opinions, plans or strategies of Commvault Systems, Inc. ("Commvault") and Commvault undertakes no obligation to update, correct or modify any statements made in this forum. Any and all third party links, statements, comments, or feedback posted to, or otherwise provided by this forum, thread or post are not affiliated with, nor endorsed by, Commvault.
Commvault, Commvault and logo, the “CV” logo, Commvault Systems, Solving Forward, SIM, Singular Information Management, Simpana, Commvault Galaxy, Unified Data Management, QiNetix, Quick Recovery, QR, CommNet, GridStor, Vault Tracker, InnerVault, QuickSnap, QSnap, Recovery Director, CommServe, CommCell, SnapProtect, ROMS, and CommValue, are trademarks or registered trademarks of Commvault Systems, Inc. All other third party brands, products, service names, trademarks, or registered service marks are the property of and used to identify the products or services of their respective owners. All specifications are subject to change without notice.
Close
Copyright © 2020 Commvault | All Rights Reserved. | Legal | Privacy Policy